Some guidance with Asset Manager

Hi peeps, I’ve been reading a lot of the forum which has inspired me to try and create a custom mod, eventually I want to be able to merge several mods but thought I would break the seal by trying to recreate some of SnG along side class changes to boost maximum skills & level cap etc.

So I’m having a very strange experience trying to mod the game
So managed to extract games files with AM nps, I copied the AoM content from gdx1 over Base game, then FG content from gdx2 over that.

When I first tried I modified the extracted files directly when I rebuilt it it worked fine. My problem now is I am trying to do it the right way by creating a new mod, mainly due to the rebuild time it takes ages to recompile the whole db which creates a 107mb file. So I copied all the records I edited into a new mod tried to rebuild it and none of the previous changes appear in game, when I check the output in the build folder the altered .dbr’s are correct but as I said none of those changes are appearing in game.

So I guess the main question should be is this because I merged the gdx1 & gdx2 folders with the main game? Meaning if I want to do it this way I HAVE to work on the extracted files and recompile the whole thing each time I want to build?
Also would this explain why I am unable to import some records into my mod, for example db/rec/creatures/pc/playerlight.dbr wont import but db/rec/creatures/pc/playerlevels.dbr will.
I am thinking this is a source problem maybe? but I am not sure as there isn’t any useful error messages coming out of AM.

Thanks =)

Whatever your problem is, it is not related to merging the expansions with vanilla, your mod would have to do that anyway as you can only have one .arz

I assume you did not actually select the mod in game…

@mamba thank you for that info!

So a little update from last night (this is kind of a running dialogue as I am debugging this morning so please excuse the ramblings :rofl: )

I definitely selected the new addon, I have just tried again just in case I hadn’t selected it but still not seeing the change, when I switch to the old version and using the char I created for the new mod and the changes were there.

Now one thing I did do, was when I made the new version I did the “new mod” in AM then closed the app and I copied the files I edited into the db structure myself and then opened AM again, where I was greeted by my altered records everything looked good and it built it with no errors, even the dbr files in the build folder are the correct edited versions so that shouldn’t be an issue.

AM also wont allow me to import some records using the menu I just get “Error Importing database record” but if I right click inside the right hand window and import the file directly it seems to add it ok.

However as I was writing this reply I have just noticed the file size of my new mod is only 623kb yet the db folder is 3.5mb which suggests its not actually building my mod properly, rebuilt it just a moment ago and I don’t remember it giving me a choice last night but this time it gave me the choice to “delete un-associated records” (which was basically every file in the mod) I said no it rebuilt the db to about 1.2mb and the changes appeared in game. Yay a win… kind of lol

So have I missed an important step in associating records somewhere, and is the import records error something you’ve had/heard of in the past?

There are no associations you need to maintain for dbr files.

I guess this question refers to dbr files that are in the compiled mod but no longer in the source, and these would be removed from the mod if you agreed to it (which you generally should…)

So I would check if the compiled dbrs contain files somehow that are not in your source and then decide if you need them (in which case you should copy them to the source) or not.

I’m going to do a fresh extract and go through the setup of AM again to see if I did something wrong or missed a step somewhere. Its very odd as I can see all the files, and doing a manual import via in the appropriate tree adds it without error.

I made the mistake of saying “yes to all” when I tried to recompile the mod this morning and now it doesn’t give me the option anymore and now it won’t recompile with the files again head-desk so have to restart anyway now.

Oh how I wish there were better texts available to using this esp troubleshooting this import record problem. Righty off to swear some more, again thanks for the info hopefully I’ll get to the bottom of the issue.

@mamba I think I have discovered the root of the issue, from another forum post.

Looks like I was missing the *.arc files from the resources folder apparently that causes AM to delete any unassociated records when it builds the mod, which was exactly my problem and why it worked fine when I told it not to. =D
(thanks to @ASYLUM101 [In this post…] (Trying to modify the Grimallion mod.) really helped!)

Still can’t import records though, it can happily see them but just gives the error makes me wonder if I’ve got the right additional folders.

I extracted to D:\GDMod\working\ and gdx1 & gdx2 are in .\working\mods\ which is where I have set the additional source to

I have a second copy of Grim Dawn I copied to the D:\GDMod\Grim Dawn\ which is where I extracted and am running the tools from, the main game is in steam folder

As I said I did the gdx1 over base then gdx2 over that so when I browse for the records I get everything listed nps at all… makes me wonder do I need to copy over any other files to the mod directory like the above *.arc’s

But I did manage to merge Grimmest, Smash N Grab, Big Caravan & made all shrines corrupted shrines like in GD Reborn and have been able to get to work expanding the skill tree to cope with the new level cap of 200 then comes some real challenges, monster scaling and adding prefix & suffixes to rare/set & legendaries.
Cooking with Gas now =D

The content of the arcs would get deleted if you have no corresponding source file and asset file in your mod.

Similar to how dbrs would be deleted from the arz if you no longer have them in the source dir.

If you do not change resources, simply continue using the existing arcs, but do not expect your mod to create them.