(Spoiler) Tomb of Herald Mathis

Anyone know how to enter the secret crypt in the Tomb of Herald Mathis? You kan spot it in the left down corner of the almost at the entrance of the tomb.

Attachment: Grim Dawn Screenshot 2017.10.12 -

Where is that area even?
I’m sure it’s related to that weird message found in a quest in Malmouth, had something to do with a Herald resting place.

Between the Steelworks rift gate and the place where you do the harbor opening quest, you pass by the tomb. Couldn’t find the way into the lower left, only was able to find the path to the smith that makes legendaries.

All I could find is an unlit wall mounted torch in one of the first rooms but I can’t interact with it.

Could it be that it’s only available in Ultimate like the Stormheart quest?

I think it’s only possible to do if you don’t give her the note back.

I did her quest in ultimate, and handed the note in to her. Maby I will go back to elite, and find the note again, and ceep it, and give it a go.

It worked, keep the note in stash, and the crypt unlocks.

So what’s in there then? Inquiring minds want to know!

3 personal stashes (just like heroic chest). Somehow one of those Ivonda’s stashes is bug, I cannot reach it, the top right one.

Where is he bro? I keep finding but no luck.
EDIT: Nvm found him in same herald themis, middle.

dude, hold shift and attack the bench - or something i don’t remember

So it is official that if you give her the note back you lock yourself outside of this area?

That kinda suck being a good guy limiting where you can go. Guess will keep it next character.

This torch doesn’t work for me AT ALL. :furious: I tried everything and it just doesn’t work. Different difficulties, clicking it with and without memory, after and before talking to ivonda, after and before finding memory, after and before giving memory to ivonda. This fucking torch is never active. :furious: Why the FUCK is it working for other people, but not for me?
Cursor is right above torch, memory in inventory, doesn’t do shit :furious:

Bump, this is frustrating.

It is not bugged. You have to destroy a box blocking it first.

Have the same issue - tried on different difficulty - doesnt work :frowning:

Noticed Ivonda only after being knee deep in Crown District. Where do I drop here note (“memory”)? Kinda lazy to thru steel district again.

I was very nonplussed about hearing this AFTER I turned in the memory. Stuff like this makes me itch to practice my Ti Kwon Leep.

So I have her memory (diary) in my inventory, torch is not clickable. I tried clicking on it before reading the note and after reading the note and no success. Still have her memory, even tried to talking to her to deny her her diary, but torch is still not clickable. Annoying.

So reloading the game helped (diary was in inventory, note was already read)