The Steam Cloud setting issue - I did not expect this boost!

I have played this game from the beginning and did set the STEAM cloud synch OFF within the STEAM properties from the word go. I did not however change the Grim Dawn options to set Cloud Saving off in the game options menu as I thought that the STEAM setting would override it.

My understanding was that within Grim Dawn the Cloud setting just changed it’s save folder location between “C:\Program Files (x86)…” or “C:\Users…” and if I had the STEAM cloud setting set to OFF, then all that was different was the location of the save file folder.

I left it like this as I was lazy and already had a SyncBack app profile which backed up my Grim Dawn saves to an external source.

I have now actually got motivated to set Cloud OFF in Grim Dawn and move my saves and the SyncBack settings to the “C:\Users…” folder.

There are MANY threads on this forum that explain how to do this.

All I thought was going to happen was that the save and backup folder location would change to what I wanted it to.

I got a pleasant surprise when I ran the game after changing the save file location. I always had the occasional stutter when moving around, but it was never serious enough to concern me. Now the games runs almost 99% stutter free.

In conclusion I would now agree with the consensus of lots of posters out there that recommend disabling BOTH cloud setting in STEAM and Grim Dawn options.

I have no idea why I got so much more performance on my machine from doing this, but I did notice that if Grim Dawn settings are set to cloud, then there is a file in the save folder called “remotecache.vdf”. Maybe this file gets hammered by the game to try to keep sync with the STEAM cloud even though you have STEAM cloud disabled?