[TOOL] GD Switcher v1.2

i’ve gotten the zip thingy, you can go ahead and take it down . . . . i may return shortly with questions!

thanks again <3

Thanks for letting me know.

If you have any questions, you may want to ask in my thread mentioned above. I don’t want to clutter powbam’s thread with graphics stuff. :wink:

Switcher “1.2” is here (check the OP). Rewritten in Python. Hopefully just the first of many updates to come as I build on new features. For now it just does its “core” purpose.

1 Like

If only I had this months ago…

Instead Crate got more money from all my friends lol

1 Like

Yeah sorry bout that. I’ve actually been sitting on a “more” complete version for some months now and then I took a bit of a break, decided to learn some Python, and then rebuilt it. And I kinda “partially” accidentally let the old links for the last version(s) get messed up with my Mega account and I didn’t have 'em on my computer anymore.

So, Switcher has been in a sorta dry period for a lil. Dry periods over tho :slight_smile:

Sneak Peek

Just a little preview of some toggles I’m working on for Switcher’s next update.


So I have been trying to download this and nothing happens when i click the download link. is there another way to get the download?

Ahh it appears that Max’s download for it is broken now for some reason - and I actually don’t have the source for this old version anymore.

However, I have been slowly building a newer improved one (old one was in Python, new one is C#) which you can download and use here…

GD_Switcher.zip (1.7 MB)

This version might require that you have .Net Runtime 4.8 installed (if it currently isn’t on your system) so if it has any issues functioning correctly you might need to install that…

Do note that the GOG side of things in it currently don’t work and only the Steam side functions correctly, sooo if you are using GOG you will have to wait a bit til I get around to that side of things.

1 Like

Just a small feedback for whatever reason it look like that last GD Switcher may have some issue with GOG galaxies. Runtime already installed obviously.

Can select Gog the Path, but after that it look like the UI is still reactive but nothing happen.
I cannot validate dx9 or dx11
What I tried:

  • create the gd-switcher folder in my game.
  • run in administrator and deactivate Avast.
  • I tried the path steam, that look like ok until we launch the game (obviously :stuck_out_tongue: ).
  • I tried without gog galaxies launch and with.

If someone have solution it would be neat.

This is because GOG, unlike Steam, does not have any functionality (that I am aware of) to launch the game in Galaxy outside of Galaxy, instead it launches the game directly from the installation folder.

If you ever learn if there are launch commands to do this I would love to know and I would then implement it. Otherwise, there is sadly nothing I can do about it.

Edit: I just did some new Google searching on the topic and this time I (finally) did find something that may be promising to enable launching a GOG game via Galaxy. I have to test it out first to see if it works but if it does I may be able to have an update for it in a day or two. Cross your fingers I guess and we shall see

Thanks for the rapid answer.
ok so the API is setup for future (two days is not that far future) but this is a known issue.
Do you have a git with that somewhere ? I understand this maybe problematic in some company to open source this kind of software as it may rely on some usable pattern for hacker.
As far that I understand this look llike just a command line option of the GD executable itself.
What are this switch because if the external API of gog do not allow it or make the life to complicated we can setup manually the switch in GOG launch argument . This is not suitable for all user but this is a solution.

Nope I’m just a lone coder who made this tool “just because”. I haven’t ever gotten around to learning to use git/github etc yet. Maybe some day.

Indeed - custom command ‘switches’ are exactly how I call GD to launch it via Steam. GOG’s Galaxy presumably does not have the same functionality as Steam but the user BKGaming_ in the reddit post here:

…has detailed a method whereby I might be able to make this work. I will look into this asap.

If you wish to know what custom commands the GD executable accepts (and are the ones that I use):

  • /x64 ; for 64-bit version
  • /d3d9 ; to launch in DX9
  • /nogdx2 ; disables Forgotten Gods
  • /nogdx1 ; disables Ashes of Malmouth AND Forgotten Gods both

To launch a game application in Steam via external methods (for GD in particular), you need this command:

  • -applaunch 219990 ; the 219990 is GD’s SteamID number and you can then follow it with any of the above commands
1 Like

I just tested out the method detailed at the reddit link and successfully launched Grim Dawn with the Galaxy overlay intact.

Here is the command needed (the “Target” being the GalaxyClient.exe located in the root GOG Galaxy folder):

  • /command=runGame /gameId=1449651388 ; with 1449651388 being GD’s GOG game ID

Other than that the shortcut then needs the “Start in:” path to be pointed at GD’s install folder.

I’ll try to get Switcher updated for it today possibly.

Edit: After messing around with this I am so far UNABLE to get the shortcut to launch with command variables like /d3d9 or /nogdx1.

I may not be able to update the tool with this method until I get that figured out, if even possible. I can launch the game… but I can’t modify it after that point.

There are no need to rush I think, as I am the only feedback about that since 29 days.
I tried to edit a launch configuration directly in gog (you can edid in gog and say launch labelled command line etc etc) via the option, but I am stuck on black screen even without any option. Gog will be maybe a little bit more capricious that you thinks :stuck_out_tongue:
what I did basically, I take the standard config (The one that work and launch the game) hit duplicate button (even tried to set default). And I am stuck on black screen.
From outside this look like a bug from Gog that do not “duplicate” the whole configuration but hard to know.
A rapid research reveal that they may have some default parameter hidden by gog that arent copied with the duplicate button.

ok more simple apparently you can just point to the grim down executable and launch it with the command line handler. And bypass completely gog Galaxies the game somehow find the gog galaxies ID look like you can join multiplayer.
In the install folder there are even some shortcut that you can edit.
I feel a little bit stupid to do not tried that first :stuck_out_tongue:

1 Like

@coucouikmf - I just remembered…

…from my post above I specifically mention that GOG version currently does nothing with the tool as it currently is :smiley: Sorry about that but I completely forgot I hadn’t extended that side of the feature set yet with it. And yes it appears that the multiplayer will work without Galaxies overlay and whatnot from what I can see.

I didnt see this quote.
As I said I dont thinks this is concerning a lot of peoples.
But at least there are a suitable solution for it. Even if it imply some manual configuration.
Create a direct to executable grim dawn shortcut with the switch that you provide.
Will solve the issue of peoples here.
Apparently there are a shortcut template created by gog in the install folder.

1 Like

Indeed :smile: My program is very niche.

I’m glad you were able to figure out a suitable workaround in the meantime. Happy gaming.

A post was merged into an existing topic: [Tool] Grim Internals

pow did you incorporate the menu switcher into this 1.2switcheroo? - or have i been sharing the wrong switcher link ? [Request] Main Menu Selection - #47 by powbam

Um I dont think I did. Awhile back I was working on one that did but I think I stopped. If I ever get some time I might just rebuild it again. We’ll see.