[Tool] Grim Search

If you mean finding duplicates across all characters without specifying one character - then unfortunately no. The usecase of the duplicate search is specifically “I’m on character X - what can I get rid of (sell off)?”

Copy-paste is now supported (no formatting though). Latest version out on github.

Yep, that’s what I mean. Thanks for answer.

This morning I added support for searching for blueprints in Grim Search.

As always you can find the latest release here: https://github.com/hallgeirl/gd-item-search/releases

Enjoy. :slight_smile:

I’ve just released a new version of this tool that GREATLY improves responsiveness by doing much more work asynchronously. Additionally, an auto-refresh option has been added, and the last search string + search mode are remembered from the last session.

Get it here while it’s hot! https://github.com/hallgeirl/gd-item-search/releases/download/v0.2.4%2B2/GrimSearch.zip

Search “resist” works ? Or only damage…

Hi! Looks like the tool does not detect most of my characters. Probably only the old ones, created before AoM, are detected (not sure). No blueprint is found neither (only some strange “Crafted completed” item). Could you please advise how to fix that?

I noticed similar issues today. After fiddling around it seems that any character I’ve logged into since the latest patch has had their items disappear from search. I have a feeling this somehow related to the or patches because the tool was working great prior to those updates. changed the char save file format

@hal9001, you will need to add the following in your PlayStats.cs after

        if (version >= 9)
            survivalWaveTier = file.ReadInt();
            greatestSurvivalScore = file.ReadInt();
            cooldownRemaining = file.ReadInt();
            cooldownTotal = file.ReadInt();

if (version >= 11) {


SkillMap::const_iterator it = skillTrackingMap.begin();
while (it != skillTrackingMap.end())






the above obviously has to be translated to your tool / CSharp, but it should tell you what is needed

This tool has been quite helpful to me. I hope it gets updated.

Hi everyone,
I didn’t play GD after the update so I’m afraid I didn’t notice this - thanks for letting me know. I’ll make the fixes required to get it up and working again.

@mamba - thanks for the pointers on what to fix!

I’ll let you know when updated.

I’m happy to say that the tool is functional again - at least from my testing! It’s available here: https://github.com/hallgeirl/gd-item-search/releases/download/v0.2.9%2B1/GrimSearch.zip
Thanks again to @mamba for providing the details needed to do the fix - otherwise it would definitely have taken a bit longer to figure out :slight_smile:

With any new version of Grim Dawn, I would advice to clear the items cache (Settings => Clear items cache, then Save). Otherwise you may experience that not all items are there, or have their stats updated. It’s a bit time consuming, which is why I haven’t added anything to do this automatically.

I guess an alternative would be to ship the items cache file, but I’m unsure if this is OK from a license perspective…

Anyhow, please let me know in this thread if you still experience issues.

To answer a few of the questions as well:
@MDzerg - currently only damage types are searchable, not resists. Resists are very relevant, so I’ve noted it for future development. https://github.com/hallgeirl/gd-item-search/issues/15

@Sotnik Strangely I did not do any change to the blueprint loading code to make it work with the save format - can you update the tool, clear the items cache, and let me know if it’s still an issue? If it is, could you please send me the formulas.gst file from your saves directory? One way to send it is to create an issue on Github on my Grim Search project and attach it there.

The blueprint indexing issue has been fixed as well now. Thanks @Sotnik for providing the formulas.gst file that reproduced the bug.

New version - 0.2.10: https://github.com/hallgeirl/gd-item-search/releases/download/v0.2.10%2B1/GrimSearch.zip

Actually, It was not me :).
Thanks @unknownbenefactor!
And thank you, hal9001! I could not imagine how to play GD further without your tool. Now there is no need to sell all these legendaries which do not fit in the shared stash! Time to turn all my 100lvl glorious heroes into rightless mules!

Meanwhile, could you please advise if there are such functions as ranging (by lvl, for instance) and turning the pages of the list (as 50 on screen is max).

Hey thank you for this great tool!
I just downloaded it, but unfortunately every time I try to save the save file paths in the settings tab some error message pops up, saying: An error ocurred while saving settings: A part of the path “C:\Users****\AppData\Local\Temp\GDArchiveTempPath ext_en” could not be found.

I looked that up and there is indeed no GDArciveTempPath folder around.
Did i miss something?

It’s definitely possible to limit the searches by level. Just set a value in the “Level range” textboxes. They default to 0 and 100, which means everything.

Currently paging isn’t supported I’m afriad - it’s on the todo list. :slight_smile:

Hm, that should indeed not happen. However the missing GDArchiveTempPath folder is no mystery - it’s used by the application to extract the database files containing all item definitions etc., then these are cached into a JSON, then this folder is deleted.

Do you have Ashes of Malmouth installed? I have not accounted for that currently, but shouldn’t be much work to do, so let me know if not.

If you do have AoM installed, could you please do the following:

  1. Download the latest version - 0.2.11 - from here when it’s available in a fe minutes: https://github.com/hallgeirl/gd-item-search/releases (it has some more debugging options that I just added)
  2. set debugMode to “true” under “appSettings” in GrimSearch.exe.config (same folder as the exe). Also set the “cleanupArchiveFiles” setting to “false”.
  3. Inspect the Log.txt file to see which file failed to be processed. And look in the temp folder that you tried to find earlier, and please report what you see

Yep, I have AoM installed. So I downloaded the new version and followed your instructions for the GrimSearch.exe.config settings. Then tried again. A rather big error message came up, I have attatched a screenshot.

I also had a look at the Log.txt, but could not find anything that looked like an error to me. (But I am no programmer, so I’m not too sure about that.)
I have attachted that one too.

The GDArchiveTempPath folder now remains in the AppData\Local\Temp folder, but is empty.

That is indeed odd!

Can you confirm that this is the correct directory for Grim Dawn? d:\programme\steam\SteamApps\common\Grim Dawn

And if you look for these files, relative to the Grim Dawn directory:

Do they exist, and what are their sizes?

For now however, I have a workaround for you. I’ve attached TagsCache.zip, which contains TagsCache.json. Simply put this .json file into the Grim Search directory. Then you should be able to avoid this issue. I would greatly appreciate if you could give me the details above though, so I could get to the bottom of this. :slight_smile:

Hi! Could you please advise if the tool allows searching in the shared stash and among the learnt blueprints?