Tradingpost bug

if you buy heavy tools (and possibly other things as well?) and send them straight to village storage it ends up in limbo between existence and not existence, if you happened to buy multiple and dont move all of them back to trading post and only move a few or 1, then anything you didnt move gets deleted since you peered into schrödingers box and just grabbed what you needed

Currently, all items transferred out of the Trading Post remain in a limbo state within the Trading Post. They are available to the town though to consume.

This is something we want to address during Early Access.

Not sure what you mean about them getting deleted though. They probably got used up by the town.

just saw this post before I wanted to post and i think the thread creator means that you cant find the number of this ressource anywhere.

Its not in the stocking of the trading post
And its not in your storage house either.
It is “magically added/just there” when you hit “R” for the Ressource view.

Disadvantage is, that if you spread warehouses or stockyards to store goods close to the places which need them, all are running towards the Trading Post as seen in the picture:
(Tools were bought with “buy & transfer”)
And for all who don’t want to test. Buy & Stock + later transfering also doesn’t work. Same limbo state as Zantai mentioned.

So I guess you distinguish between goods actually in the warehouse (this cant be consumed by the villagers) and another stock which is used after “buy & transfer” which can be used by villagers.

I think adding a “Stock Count” for this “Magic usable Stock” would help immediately with convivence and is hopefully not as hard to program as the instant transportation to the right place thing.

i bought two “heavy tools” from a trader and in the trading window chose to “buy and send to town storage”
then i tried to find the item in the town storage and couldnt, so from the trading posts menu i tried to transport 1 of the “heavy tools” to the trading post again, and i watched how the NPC in charge of the trading post went to fetch something with the wheelbarrow, and on the way back they werent carrying anything but the other “Heavy Tool” that were supposed to be in Town storage was gone
then i tried to send the one i moved to trader post back to town storage and that got instantly used on the windmill i had built, i had originally bought two “heavy Tools” in order to have two windmills , but now im stuck with just 1
so either the item just got deleted or the windmill somehow uses two “Heavy Tools” without actually showing that it does

I am curious as to why when selecting trader that the picture is partly off screen. Is there a way to lock it to a part of the picture so it can be accessed without having to drag it across the screen to interact?

Did you rescale the UI?

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.