[Tutorial]Use the archive tool to uncompile *.arz and *.arc

I tried to do this but when ever I enter the command I get a window pop up saying this app can’t run on your pc. to find a version for your pc check with the software publisher

how to pack it back through cmd?

please I need help.

Sorry for my english.
I need to change the skill “Blood of Dreeg” because cooldwon (60sec) is more longer than the time it stays active(45sec).
I unzipped the Ghost-Grim.arz database through ArchiveTool and edited its time from 45 seconds to 450 seconds.
But now I don’t know how to repackage in Ghost-Grim.arz format
I tried using the -add command for example “archivetool XXX.arz -add XXX 1” and it works, but the Ghost-Grim.arz file is 60mb instead of 5mb which is the original size. When I run the game, it crashes.
I tried changing the number from 2 to 9, but none works, only 1.
How do I compact the folder to the .arz file?
Thank you very much.

Life saver, appreciate it.
谢谢

Oh boy here we go lol. I get so confused by this kind of stuff. Can anyone take a look at what I’m doing wrong? I am trying to extract a mod’s .arz to my folder “Mod Tools” using the ArchiveTool and every variation of the command I try seems to give a different error (granted a few I had typos on some of them). I tried my best to copy what I saw in the tutorial instead just using my own file paths, and putting quotes around the paths with spaces (as Ceno suggested) but nothing seems to be quite right. Ideally I am close and just missing something small?

I think your mistake is not putting the .arz file in quotes in any of your attempts.
The following works for me. I used %cd% (current directory) to not write full path:

C:\Program Files (x86)\Steam\steamapps\common\Grim Dawn>ArchiveTool.exe “data base.arz” -database “%cd%”

(needed to enclose data base.arz in quotes since it contains space)

In your case the command is

ArchiveTool.exe “Grim UI X-Mod.arz” -database “%cd%”

if you’re doing everything in the folder where ArchiveTool.exe and zlibwapi.dll are


Here I copied those two in a new folder and unpacked my “data base.arz” :

and there are actually files in there

image

PS In my Windows 8.1 to open command line in current window I have to Shift + Right Click in that window and then select "Open command Window here"

Awesome, that got it to work! Thank you so much!

Please write an example of how to pack a folder into an archive using this utility

Very rudimentary my way.
As an example, if you want to make a rainbow file (Text_EN.arc) for the Grimarillion:
create_arc

As a preliminary preparation, create a folder named “temp” and place Grimarillion’s rainbow files there. This folder can have any name, here “grima”.
Also, copy ArchiveTool.exe and zlibwapi.dll from “Grim Dawn” to the temp folder.

Grimarillion’s rainbow texts has a hierarchical structure as shown in the screenshot. Since each folder has its own texts, the hierarchy must be maintained when the texts are converted to an arc.

So, create a text of the following command and change its extension to “bat” to make it a batch file. Click on it, and a minimum size Text_EN.arc will be generated in the temp folder, keeping the hierarchy.

[arc.txt > arc.bat]
archivetool.exe "Text_EN.arc" -add "." "grima" 9

1 Like

Спасибо, все получилось

that’s how i extract arz/arc file

win+R cmd

“E:\datatest\ArchiveTool.exe” E:\datatest\file.arz -database “E:\datatest\1”

if u had error check, there shouldn’t be > “_” > E:\datatest\dom.arz

done