Using ArchiveTool to inject a modified file into original files?

Hey, I now made a small mod that makes some changes to some text-file, and it also works as I want.

I’d like now to inject this modified file back into the original resource files so I can use it with characters in the normal gamemode. Luckily the files aren’t hash-checked or anything and I was e.g. able to remove some txt files from Text_EN.arc with the -remove option and still start the game.

But I’m yet unsure how to use the add, replace and update functions. Especially, what does mean in these cases? points to the directory or file you wish to inject I’d guess? I tried around a bit but couldn’t really figure it out.

Also what’s the compression values used for the original files?

I can’t help you with the ArchiveTool, but with Asset Manager you can make a mod and create Text_EN.arc yourself.

You will have to set up Asset Manager first.

Just extract the files from Text_EN.arc, create a mod, in folders source/Text_En you paste all the files, make the changes, In Asset Manager select all the files->right click->Auto create Asset, then you build the mod and you should have your Text_EN.arc in folders modName/resources.

1 Like
  1. For text files just make own community localization achive and select it in options.
  2. For any resource file you no need even pack it back, just place in “/source”, saving file hierarchy
  3. For any database records you have to repack original files
    Anyway for 2 and 3 check Modding tutorial section, there good enought tutorials for modding tools
  1. That’s a very good option and is what I did now. Works like a charm.
  2. I tried that one too but didn’t manage to make it work. Just to be clear, you meant e.g. “source/text_en/*.txt” ?
  3. Noted!


Hmm, that one I didn’t manage to get working.
I made a folder “source/Text_EN/” in the Grim Dawn folder into which I placed the “tags_storyelements.txt” file I modified, but it doesn’t overwrite the default one.

The hierarchy seems to be correct, as when I compile the mod and start a new game with it, it works.

It could maybe be because the mod needed to have an asset?

Sorry, my mistake. Not “source” but “settings” folder: settings/Text_EN/tags_storyelements.txt

Yep, that one worked as well! Thanks!

Ahhh, I’m bothering again. Do you know how todo the same with the expansions? I tried making a settings folder in gdx1/ and gdx2/ but that didn’t catch it.

Files for expansions also plases in same settings folder.

The only option I didn’t try. Much obliged!