Weird Sound Issue - Problem Identified!

Whenever I am “above” enemies on the screen the sound effects that I should usually hear are either muted or very low. Other wise the sound is normal. So if I’m in a situation where there are a lot of enemies, the sound from below me is gone but I only hear what is going on north of me.

I tested this out with noise making objects, such as a thermite mine or even the portals found on the map and the same thing happens. When I move around the object the sound is fine, except when I get right north of it, and then the sound disappears abruptly. This make the whole game sound odd.

I think I noticed something “off” a while ago, but I thought maybe things have changed since I hadn’t played in a while. But now I have identified what is going on exactly.

I watched some old videos of my gameplay and this was clearly not happening before. I don’t know why this is happening all of a sudden, and it is making the game unplayable as I rely on sound cues.

EDIT: I tried playing on my laptop on the lowest settings and the sound was fine. Something really strange is going on with my desktop. Could anyone give a clue as to what happened? I noticed that my sound driver was updated last March, but I can’t roll back. But would that have anything to do with this weird problem?

I tried making several videos and the enemies weren’t cooperating to make the issue more obvious, but I think you can still hear the differences.

What Operating System are you running? Just asking, because the latest Windows 10 64 bit update borked my sound drivers, both the Realtek HD Audio drivers and the NVIDIA HD audio drivers. Lost sound completely in some games and PC apps, and had odd directional sound in others (like speakers not playing sound, but headphones playing it, but not correctly). Had to download and update both sets of drivers to restore normal audio to my desktop.
No issues on my laptop, which still runs Windows 7 64 bit, but I have not tested a ton of games or apps on it since the last Windows 7 64 bit update.

Yes I am under Windows 10 64 bit. I had this problem before today’s update. After reading your post, I updated my realtek audio drivers but the problem still persists. I actually don’t play action games other than Grim Dawn, but I did still have Titan Quest installed, and I have no issues in that game. This is quite frustrating.

Thanks for trying to help, though!

Actually it was the windows 10 update! I was wrong about it happening before today’s update. My laptop now has this problem too. I uninstalled two of the updates on my desktop and the sound is back to normal! Now what to do about the unresolved security issue…

Which two updates?

Medea: They were “cumulative” updates. The other two was an adobe security update, and the other was labeled security update, but it seems that the cumulative updates covered security issues as well. I am actually in the annoying process of trying to identify which one of the two is causing the problem, but I will continue this tomorrow.

Powbam: I actually saw that article earlier today. If only good games would be available on better operating systems, I would have dropped windows long ago.

Well, if it matters any the last times I gave GD a whirl on Linux (Manjaro) it ran near perfectly in Steam Proton, good performance even - almost on par with Windows native performance. For non-Steam versions it is my understanding it is working quite well with base Wine too.

Fucking Microsoft. I had this exact same issue as well. Uninstalled the last update and sound went back to being perfect.

Anyone know how to stop windows auto updating as I fucking hate it!

If you have the Lenovo Vantage app installed, uninstall it.
I did not have it installed on my desktop, and downloading and re-installing the sound drivers, then rebooting the PC solved the sound issues I had. May or may not work for you, your build is likely to have different HW and SW than mine does.

(Quick edit- check your wifi and bluetooth settings as well. The previous update changed my bluetooth settings, and turned bluetooth connectivity on. I had it turned off, because… too many bluetooth devices in my household and neighborhood that would/did try to auto-connect to my PC when they were in range. That irked me a whole lot.)

There is a guide here, but if you are not really, really, REALLY sure what you are doing, better take a full disc image to restore your PC in full if you screw it up:

Well, after using the pause updates feature, I pressed the resume updates thinking that it would give me options to choose what to download but it just downloaded all updates automatically and I couldn’t stop the process. Afterwards it seemed to merge the two separate update into one called: Cumulative Update for Windows 10 Version 1903 for x64 based systems (KB4515384). So the individual update that is causing the problem will be different depending on when the user last updated.

Good to know. Unfortunately, I don’t know the status of my other games, but I will look into it.

@EvilGinger: I did not reboot my system after I updated my sound driver before. I may have to try that, but this is annoying because the cumulative update takes a long time to both install and uninstall. I will try to see if it does anything for my laptop before my desktop. If it doesn’t work, my desktop will temporarily have a security issue until I can find a fix. I do not have Lenovo Vantage app and my internet goes through ethernet as it has no native wifi or bluetooth.

I seem to have resolved the problem. It seems that the new update doesn’t work with realtek audio drivers, both older and most recent.

So after checking out this link:, the section “using a generic high definition audio driver” fixed the sound on my laptop. I went ahead and reinstalled the windows update and switched to the generic driver and it is also working normally on my desktop.

When I have the time and motivation I will look into switching to linux.

Yup, I have a “slightly” older rig (bought it from Digital Storm years ago - with Win7 installed at the time) that has Realtek hardware. Ever since switching to 10 it has had audio issues.

With a bunch of hunting around on what to do it is possible to mitigate the issues. A bit of a pain in the ass tho.

There’s some more info here with a workaround and how to uninstall the update.