Can't get Titan Quest to load...please help?

At my wit’s end, not that it’s saying much.

I went back to play some TQ:IT. Alas, Direct 2 Drive had me reinstall and re-input some codes and stuff, but after the hassle, was having fun, of course. Then I got a new computer. I put the half-gig of my old characters on a flash drive in preparation.

I re-dl and re-install TQ, and TQ:IT, no big deal. I re-input the activation codes, no prob.

But when I double-click to open up the game, I get the message asking about making changes. I click “yes”, the box closes and…nothing.

I’ve set my firewall, I’ve uninstalled/reinstalled, and I tried just doing TQ to see if I could get the game to run.

No dice, repeatedly, and Direct 2 Drive says I should contact the publisher for support.

Anyone here able to suggest something I could try to get this beloved game to run on the new computer? I promise my drivers are up to date and the new rig is up to spec.

Attachment: Titanshot.jpg

I am sure people would love to help, but for now, I am at a loss to understand the error.

Take us through the steps of launching TQ without IT and what you see up until and including the final error.

You are trying plain vanilla? Not even the fanpatch, right?

You launched the games before copying over your save data from usb key?

Just plain vanilla (1.30?), no fanpatch.

I haven’t copied over the USB data or anything.

There’s no error message.

I double click on the icon to start up.

I get the “user account control” box that asks “do you want to allow the following program from an unknown publisher…” box that I get on many games. I select “yes” and…that’s it.

The box closes and nothing. The game doesn’t load, there’s nothing in the taskbar. It seems like a firewall problem, but adding the .exe to the firewall permissions manuall still doesn’t help.

Unplug your network, reboot and try again. TQ from D2D has not had any updates right? Still uses Gamespy I guess, which is offline, so wtf is TQ doing borking on a network request? I would try to get the game running offline if possible…as a first step.

jiaco Unplug your network, reboot and try again. TQ from D2D has not had any updates right? Still uses Gamespy I guess, which is offline, so wtf is TQ doing borking on a network request? I would try to get the game running offline if possible…as a first step. <<

Weird idea, but at this point I’d shoot whipped cream into a USB port if it was suggested.

Anyway, unplugged the connection to the wall, rebooted, made certain no internet access.

And same result as before.

We do know what I’m talking about with the “program make changes” permission box, right? It seems like I get it for about half the games I play (I play lots of Indies–not on this computer, though, the only other game on it is DOOM, which runs fine. I’ve had the computer less than a day). I don’t think it’s network related at all.

Keep swinging guys, because I’m stumped, and I reckon it’s something silly.

The request permissions thing is for windows firewall right?

maybe it dies on the step right aft but silent, but if you keep getting this windows firewall popup everytime, i suspect that it is not working…you can temporarily disable the firewall…but that popup should only happen the first time.

I’ve got games where that popup happens every single time I run the game, and I have more than one computer…it’s probably in my settings somewhere. I run/playtest betas and stuff, so I’m generally careful.

But this issue is on as cherry a computer as it gets.

If I am thinking of the right Req. box, it is the program wanting Admin privileges to run.
I would suggest you playaround with the compatablity settings to see if anything helps there - First thing to try would be disable Admin privileges, then enable compatibility for XP SP3(?).
From there play around a bit with the other settings I guess.
Also is there any TQ processes running in the Task Manager after you hit ‘Allow changes’?

Otherthing to try (if you haven’t already) would be to disconnect the internet and disable the Firewall. Then try and boot it up, if it works you know it was the firewall, if not then it is likley somthing else.

Good luck with it though mate.

EDIT: What version of Win you running it on?

Running Windows 10.

I’ve already tried the disconnect the internet thing, and I’ve manually added the executable files to the firewall exceptions.

Looking at all processes in the task manager, there’s nothing TQ related running.

Trying compatibility mode, systematically attempting all options, accomplished nothing, alas. Shame, that seemed like a good idea, thanks.

I also tried disabling the virtual memory (running from an SSD)…still no dice.

I’m sure it’s something stupid…any other tricks to try?

Don’t know if it will help, but have you set the programme compatability for XP Service Pack 2? And maybe also choose to run it as Administrator.

Click on the shortcut icon for the game, scroll down to Properties and then choose Compatability and XP SP2 from the list. And do you have DirectX 9.0c installed? The older games don’t always like the newer versions.

Yes, I tried all the options of compatibility mode, Windows 8, Windows 7, XP SP2, and whatever the other one was…all options give same result: nothing.

Running as administrator likewise accomplishes nothing.

Hmm, use an older version of directx? Now that’s something I haven’t tried, thanks. Not much optimism, seems like there’d be a different kind of crash for that, but not much to lose.

Edit: Dang, can’t even install directx 9.0c on a Windows 10 computer. Oh well, hopefully I can get another idea.

Say, I notice the whole game folders are “read only”.

Is it supposed to be that way? Seems like it’d be tough to save a game that way.

If not, can I get a slow and careful way to change this setting? I’ve tried the obvious ways, but it keeps resetting to read only, which means there’s more to it than just doing what the computer says to do.

Try to set UAC to “Never Notify”

If you can (not sure in Win10) disabling the firewall completely, rather then allowing the .exe, might help due to other components/services trying to do stuff that are getting knocked back. By disabling the firewall nothing can get in the way that you might not expect. I know when I want to play a game on LAN (eg AOE 2) I have to disable it completely in order to see anyones games and vice versa, just adding it to the exception list doesn’t help.

Also what videocard do you have? Updated drivers and all that? Just noticed noone’s mentioned that yet.
Also has it defaulted to a integrated video card or somthing? I know GD doesn’t run on them so it might be a problem as well.

Disabling the firewall is easy to do…no dice, same thing as before.

I have a GTX 970…the whole computer was built three days ago, I don’t see the driver as being much outdated.

I don’t know about “defaulted to an integrated video card”…how could I determine if that’s happening?

Guess I’ll try setting UAC to never notify, but I’m not convinced that’ll matter.

I just installed Defiler…gives me the same warning when I try to run it, but then loads, like every other game that gives that notification.

I assume “UAC to never notify” refers to that “program make changes” box I’ve referenced before? Sorry, I’m no computer expert, though it sure seems necessary to get games to run anymore. Oh look, a link…guess I’ll try that thanks.

Disabling it does change things. I get a little “loading” circle for about 1/5 of a second, then…nothing.

So annoying, what could that problem be.

Keep the guesses coming…

What happened here. Is this important?

Pretty sure it doesn’t save to the game folders, plus mine are read-only too.
Don’t think you’ve mentioned it yet but have you tried to install the fan patch before booting it up? Might help a bit??

I’ve never had intergated graphics so I have no idea if this thread is usefull/accurate but here you go - for setting up a profile and forcing your graphics card to play the game.

found this on a steam post about issues as well.

google search msvcr71.dll or MSVCP71.dll then copy it to c:\windows\system32 folder on win 32 bits or C:\Windows\SysWOW64 for 64 bit OS, it worked for me.

no idea if it’ll help but just incase.

whats your full System Specs. Win 10, GTX 970, ??? are you running one monitor etc. No idea if this will help but you never know.

Last thing I can think of is to set up a virtual PC on your computer and install XP or Win 7 on it to play.

Copied the DLL file…no dice.

I’m still vague on WIndows 10…do you know how I can get the list of specs off this thing? Otherwise, I’ll just go with highlights from the printout: Z1700XP motherboard, i7-6700 Processor, 16 GB Desktop Memory, 256 GB SSD HD…none of the other stuff seems like it’d be remotely an issue.

The version I have is TQ 1.30. The fan patch is like 1.17? I’m not sure that’ll be helpful, since the patch to deal with lots of virtual memory is past 1.17.

A link to how to set up a virtual PC? Thanks.

If you have d3d9.dll inside the game directory, delete it… Keep the d3dx9_27.dll.