Console Commands Reference

You can use autocomplete on files. Most arguments are an integer or series of integers. Unfortunately the debug states didn’t show information I was looking for like entity ID or x y z coordinates.

“With enough eyes, all bugs are shallow.” - Linus Torvalds

Part of the reason I’m willing to share is because we can solve things faster collectively.

I briefly played Titan Quest but the armor equation bothered me too much so I quit early. From my google-fu the console syntax seems to be the same, but the commands are slightly different wording. I’m sure other people out there have longer lists of console commands they used in their debugging. http://www.titanquest.net/tq-forum/threads/36622-Console-Commands

File paths go between double quotation marks ("). On my keyboard (US layout) I have to type shift+’ but the console registers this poorly so be careful. Example: game.spawn “records/items/bonusitems/bonus_summonwisp.dbr” (since we’re cheating anyway)

Also, console is not capital letter sensitive.
Original string dump http://www.grimdawn.com/forums/showthread.php?t=38165

I somehow managed to get stuck in a wall (temp bug I’m guessing). Anyway, I can tell you that “character.WarpCursor true” and “…false” turns this feature on and off.

Sorry for the necro, but I think it deserved it.

There are 4 checks (that I counted), all indentical - - reading/checking a certain bool value from Widget::vftable - - that if patched (0x74 to 0xEB - JE to JMP) will allow console to work at any time: 1 when game loads and initializes the Widget (main menu), 1 when you move from main menu to game world and there are 2 more when you exit to main menu or Desktop (when destroying the Widget).

Having said that, if allowed, I may post the fix. Else, whoever needs it, PM me.

youtube + jb6M1bTtNtI (can’t yet post links)

BR,
Sun

Tried to send a PM, have to post 3 messages in the Forum first…
I would really like to get the console working in the main campaign…

Cheers

If you’re familar with reverse engineering, you can enable it.

Otherwise you’ll have a hard time as this behaviour was not intended for the console.

I was hoping to get the solution from sunbeam, but it seems i have to send a pm :wink:

Don`t like to post useless posts, but have to reach 3 posts to send a pm to someone…ah well:D

Since this has caused confusion in another thread, also here for future references:

On a qwertz keyboard, the correct key is ^ (the key below esc) to open the console.

is there a command to scale xp?

could i able to change to key bind other than ~ or ’ to call the console ?

However you can use AutoHotkey for that.

This doesn’t work for me. I press the key below ESC, i’m in a custom game, nothing happens. Did they change how this works?

Do you have some different keyboard, maybe layout?
` below Esc works for me still. Check this:

None of the double pressing or shift / ctrl / alt shenanigans worked. Nothing pops up. The key that i have below esc is a \ | key and that’s the one i’m pressing

Try, maybe this will work:

config.ini:

[combo presses]
combo1=Tab:`

Every time you press Tab, it presses ` (just in Grim Dawn)
You can change Tab to a different key, even the one you have under ESC, or a letter (combo1=Q:`)
| \ or whatever you have their: combo1=\:` or combo1=|:` may work
It takes ~3 seconds for the program to start work in Grim Dawn after you maximize the window / make it active

If that doesn’t work maybe I’ll need to change the config so that it sends a specific key code instead of this `

Nothing happened with that either. I used combo1=:` which is the button below ESC for me

Could you try changing the config to some letter or Tab, for example

combo1=Q:`

?

You don’t need to reload the config after changing it btw.
The program reloads the config 3 seconds after you’re in-game.

If that doesn’t work then I’ll try sending a specic code instead of `

Of course Q should be the button for command window then.

[edit] Also you may check if it the program works at all, for example

Does Q:1 cast your 1st skill when you press it etc.

yeah it works for skills, but does not open the console, be it mapped as ` or \

Oh it works now. Turns out that the console only shows up in single player mode. I always run host server in my worlds so it wasn’t working

1 Like