Game Freezes on Windows 11 (mostly in Mourndale)

Sorry, if this is an inappropriate spot to post this, but I didn’t go to the bug report section, since there were, apparently, a lot of complaints similar to mine, yet I haven’t found a working solution to alleviate the issue.

I have issues running the game via GrimInternals, with the game freezing (usually after going to the main menu and then starting a game, I’m farming some things). Basically, I’ve tried a couple of online solutions, such as:

  1. Run Borderless Window
  2. Turn off cloud syncing
  3. Update nVidia settngs with VSync ON, power management on max performance and CUDA settings to all GPUs (I have one, but there’s been advice to do that, I’ve tried it)
  4. Removed anti-aliasing / anisotropic filtering settings (that actually helped avoid stuttering I had on some maps)
  5. Tried a CPU Affinity utility for Grim Dawn
  6. Turned off Fullscreen Optimization for both Grim Dawn and Grim Internals exe
  7. Turned shadows off

Sadly, none of that is really helpful. I mostly crash in Mourndale, when searching for the portal to Cinder Wastes. To add on top of the frustration, the crashing usually happens after a totem is destroyed. The usual scenario is – I run Hallanx, then Anasteria, then Lunal’Valgoth, then go to Main Menu, rinse and repeat. The game crashes somewhere around a second or third run like this.

I’m running a GOG version of Grim Dawn. As for mods, I’m using GD Item Assistant, Grim Internals and Wanez Tool for Grim Dawn. As for the laptop I’m running on – it’s an ASUS Gaming TUF A17 (so I assume the problem is not in the capacity of the laptop to actually run the game on nice settings).

I would appreciate any sort of advice on the matter, perhaps, someone had a similar problem?

I had this for quite some time in the past but now I don’t. Unfortunately I don’t know what I did to get rid of it.
I play on Steam Public Test Grim Dawn and Grim Internals currently.
Maybe when the game’s updated (and GI too), it will disappear for you too?

But I’m not sure if that was the reason as you can read in my quote - I had these crashes without GI as well.
Try reinstalling, I see you haven’t tried that yet.

Btw what build are you playing? I once thought it had something to do with some skill special effects.

Thank you for the reply!

I certainly hope that an update helps. Reinstalling is something I’m rather averse to do, since the setup takes some time – specifically the GD Item Assistant part. I’m a hoarder of sorts, I’m afraid, I just farm stuff and then run different builds for fun :smiley: So I hope it won’t come to that.

I’m playing the latest “stable” version, e.g.

While my answer might be a bit late, it could still be helpful to others facing a similar issue. It sounds like you’ve tried a bunch of solutions already, but the game-freezing problem in Mourndale persists. I stumbled upon a helpful Reddit community that discusses various Windows-related topics, and I thought I’d share some insights. One suggestion is to try running the game without any mods temporarily. Sometimes mods can interfere with the game’s stability, so it’s worth a shot. Also, make sure your mods are up to date, as outdated versions can cause conflicts.