GUIDE: Installing & Using 3DS Max Plugins:

Hey folks, Rhis just informed me that the secret to getting the mod textures to show up in Max is adding your mod directory to the AM’s additional browse directories!

I’ve updated the Guide in section 2 with further clarification.

Thanks! It works!

But I had to type path to source, because by default my paths were:

Working dir: C:\Program Files (x86)\Steam\steamapps\common\Grim Dawn
Build dir: C:\Program Files (x86)\Steam\steamapps\common\Grim Dawn
Tools dir: C:\Program Files (x86)\Steam\steamapps\common\Grim Dawn\

So, I typed this to additional dir: C:\Program Files (x86)\Steam\steamapps\common\Grim Dawn\mods[b]n[/b]eshes\

(Yea, I have a typo in this mods name :p)

Only thing that is left is turning off this mesh auto-move thing after project reload >.<

Thank you PrincessLuna.
I have trouble for finding the right shader/glow.
For example here is the exact same blade with same shader
IN Game / in Editor /in Inventor.
As you can see the pommel is too bright in game and we can not see the tecture.
How can I make it the same as in Editor ?

Also I would like the pfx to follow the curved katana blade but if I make the anchor entry to true not all the effect is shown (just the blue glow).


I use standardglow shader for glowing weapon or just standard for non-glowing. Specular color - 0,0,0 (black), specularPower 0.5; outlineThickness 1.
It is not the ‘right’ way (usually spec color must be 255,255,255 or desaturated blue as stated above), but it works :stuck_out_tongue:

It occurred to me that I never mentioned anything about hitboxes in the guide, which is a bit of an omission because all objects should have them. As a result, I have updated section 3 with some basic hitbox info. I will probably split that section off into a more detailed guide with pictures at some point, but hopefully that should be enough info to get you guys started at least.

As mentioned before, the mesh will always auto-move back to it’s initial pose if you have a skin modifier applied to it and try to offset the mesh. In order to move a mesh with a skin modifier, you will need to remove the skin modifier, move/rotate/scale the mesh, the reset xforms (recommended technique). Another option, which works most of the time (use at own risk) is to turn off the lightbulb on the skin modifier, scroll down to the “Advanced Parameters” tab an uncheck “Always Deform.” You then should be able to move/rotate/scale the object without it snapping back. Once you are done transforming the object, it’s still recommended to apply an xform reset (you will need to apply the xform node, then drag it below the skin modifier, right-click on the xform reset and choose “collapse to”). This will apply the xform reset and still preserve the Skin modifier. Finally, you can recheck “Always Deform” and turn the lightbulb back on. If all goes well, nothing will have exploded on you.

Looks like your specular power is too low, which results in a very wide/matte specular. I’d recommend reducing the brightness of your specular map (less white in the texture) and increasing the specular power of the shader.

As for the PFX, most sword PFX were made straight for simplicity. I’d recommend just rotating the attach point in the viewer so the applied PFX follow the general direction of the blade better. The curve of the katana is pretty gradual, so I don’t think it would look too bad.

Yhank you Allminoxy.
I changed the attach point coordinate and orientation and now the FX follow the blade.
Also I increased the specular power and now we can see the hand grip, it’s a lot better even if the glow is still too hight.

Also I made the hitbox but it was working even without it.

Hitbox? Not sure if you need it here actually…

Items will work without hitboxes (the engine will just use the mesh’s bounding box if there is no hitbox present). However, that can be undesirable at times, so it is usually recommended to have a hitbox for more accurate selection highlights. The minimum hitbox size is around .5 meters, last I heard, so for smaller/thinner items such as swords, adding a hitbox isn’t as crucial.

I have an issue with some textures that appear only on one face, wich means that if we look at the item from behind we see the texture, but if we look at it from above we don’t.
In blender viewer we see on both sides or faces , but not in Grimdawn viewer or in game.
Here is a picture , we can see that the yellow-white feather only appear from behind:
What have I done wrong ?
Thank you

Try to unify normals. Maybe some of the faces have flipped normals.
I dont know blender but maybe it display both side of the face (by default), but normals are flipped. Try to check it in 3ds max:

The feather thing is a 1 polygone only, I mean it has no width (or thickness I don’t know the right word), so must it need 2 normal on both sides ?

One normal per face. This normal must be pointing at you. Not inside your model.

Please check the first picture on that link.

For example - cube. It has 6 faces. All 6 normals must be pointing outside of the cube. If one of them is pointing inside, that face will become invisible.

Hard to say without seeing the model’s UVs and texture maps, but it almost sounds like there’s a disconnect between the texture being used in-game and the one you’re seeing in 3dsmax. Are you using the ILE shaders in max or a photoshop file to preview?

I’d double-check to make sure the engine isn’t using an older version of your diffuse/normal map (could try remaking the texture assets and rebuilding). If that’s not the issue, are you using more than one UV channel for your wings? If so, it’s possible the engine is overriding this with the first UV channel only. Only other thing I can think of is the mesh normals on the underside wings might be flipped, but it doesn’t look that way. Usually when that happens, the mesh is very dark. It looks like they’re being mapped improperly to your texture somehow.

Hi thanks for your answers as I am a beginner, Idon’t really understand, but if I don’t find I will simply copy-paste the feather an change the normal of the copied version this way it will be visible on both sides.Keep in mind we talk about a plane, not a 3D object.
Yes I am using ILE shader, with the Grim Dawn viewer.

As you can see normal of the feather have only one side,but it’s a plane , how can it be otherwise ?
I had to merge the objects from the feather with the reste of the wings, they had two different UVmap and textures but now they have the same.
EDIT: working at the same time I think it will work

Well I am not sure, but those faces “without thickness” need to be rendered as forced 2 sided but i have no idea how single face is behaving in gd rendering engine. Maybe better solution is to give them “thickness”. It is much more work, but it will be probably without issues then

Yes I am going to duplicate the object and flip normal of the copy as I don’t know if/how GrimDawn handles double sided plane textures.

Sorry, misunderstood your initial question! Yes, that is an issue with having a single-sided plane, no problems with your texture map. As stated by Skylla, you will need to duplicate the wing planes, offset them slightly and flip the mesh normals for them to show up from both directions in-game. There are some GD shaders that will force double-sided, but they are used for foliage and have no glow/normal map parameters.

ok thank you all.It’s working now

I just have a hard time finding the right balance for the specular power, is the specular power = glow power when using standarstaticglow.ssh ?
Also I don’t understand why, when setting a very low value like 0.1 it seems to set all the object reflecting the light.
I don’t want this reflec thing.
If I understand correctly the value min and max for glox power are 5-20 , right ?

Glad to see it working!

As for the specular power/glow map, there aren’t any hard rules, but I can offer some guidelines:

  1. Specular power is the tightness of the highlight on the model (1 = matte, 20+ = glossy). We usually use between 8-20 for most of our models.

  2. The specular map (in the alpha channel of your normal map) controls the intensity of the specular highlight. If you model is blowing out too much, try making the specular map darker in those spots (whiter = more specular, blacker = less specular).

  3. Normal map intensity can also affect specularity. If you are working with baked normal maps, you usually won’t have too many issues, but they can still need some tweaking depending on how you’re generating them. If you’re using something like crazy bump for the normals, then you might want to play around with the normal map intensity as well.

  4. Glow maps paired with a high level of specular (white map) tend to blow out a lot in-game. Another option is to try reducing the brightness of the glow map.

Hello, I am starting a mod for Grim Dawn, but I can find Autodesk 2012 no where. I have the 2017 version.

Am I completely SOL?