Help with setting up AssetManager for FG content

Hi everyone.
So I’m fresh new to modding and I’m trying to work a mod for my own leasure.
I followed the tutorial to set the folders for the AssetManager, including AoM and FG expansions.
However, it doesnt matter what I do it seems like the files from FG never get extracted.
What happens is that when I build he mod all the FG content are corrupted, I see it by the oathkpper skill screen that shows basically nothing.

I’ve tryied copying and pasting files here and there, but still no succes.
I’m sorry if this is a repeated post but I couldn’t find anything that could help me fix this problem so far.

Could anyone give me a hint about what I’m missing?
I followed these steps here:

Sorry, my English is not very good. It is inferred from the translation that you probably lack the template for unpacking.

You may need to Grim Dawn\database\templates.arc Unzip to Grim Dawn\database\templates\

Thanks for the reply!

I’ll try to elaborate more:
These are the paths configured in the Asset Manager:

Working directory: C:\Program Files (x86)\Steam\steamapps\common\Grim Dawn\Working
build directory: C:\Program Files (x86)\Steam\steamapps\common\Grim Dawn
Tools directory: C:\Program Files (x86)\Steam\steamapps\common\Grim Dawn
Additional browse directories: C:\Program Files (x86)\Steam\steamapps\common\Grim Dawn\gdx1;C:\Program Files (x86)\Steam\steamapps\common\Grim Dawn\gdx2
Additional source directories: C:\Program Files (x86)\Steam\steamapps\common\Grim Dawn\Working\mods\gdx1;C:\Program Files (x86)\Steam\steamapps\common\Grim Dawn\Working\mods\gdx2\

I extract the game files and everything seems ok.
I can even edit what I want in the skills and player level .dbrs, build eveything up and play it.

However, if I try to access any of the FG content, nothing is there.

Later I noticed that the content for FG were not imported in the Asset Manager, or at least I assume it wasnt.
I can actually see the files in the working folder:

But when I import the same file in the asset manager, it seems to get the file from the AoM folder:

I’ve tryied changing the paths, extracting gdx1 and then do it for gdx2, paste everything over each other (gdx2->gdx1->vanilla) and so far it’s always the same thing.
The skill tree for oathkepper never shows up.

I’m not sure about the templates but I think I have it all.

But I imagine it’s something like so:

One thing that happened, I tried to extract the templates from gdx1 and gdx2 with the archivetool and nothing happened, no folder was created and no warning shown. Is it supposed to be like that?

I’ll try your solutions and see what happens, takes a while to builds everything up.

So I just did.
Still the same thing :expressionless:

You need to supply the full path to the templates.arc…

…and noting that any paths that contain spaces in the names need to be encased within quotation marks.

Just in case anyone gets the same issue as me:
I solved the problem by copying and pasting the files extracted from the Asset Manager over the files in my mod.

Everything from here → C:\Program Files (x86)\Steam\steamapps\common\Grim Dawn\working\mods\gdx2
To here → C:\Program Files (x86)\Steam\steamapps\common\Grim Dawn\working\mods\my_mod

When prompted about duplicate files I switched everthing.
Now when I open Asset Manager my mod has all the FG files in it, and the oathkepper mastery can be used.

I didn’t check the end game content, but so far it is a progress.

Thanks for the help guys.

this is pretty common issue when using the import from database option.

This happens due to incorrect paths set up in AM.

Correct order for Additional browse and source directories is path to gdx2, then gdx1.

Oh, then I need to fix mine :thinking: I have GDX1 before GDX2. And we should also correct it in the modding guide by Elfe, right?

Yeah the guide might have them wrong iirc.

In fact, the most convenient way is to also select this item as:
Working directory: C:\Program Files (x86)\Steam\steamapps\common\Grim Dawn\

Note: The last of each line of path should \ end with , which I think is very important.

Just put the Mod you want to edit in Grim Dawn\Mods\ , so that you can try and verify it directly in the customized game after editing.

The directory structure is as shown in the figure:

Howdy :slight_smile:

My 2 cents on this given issue: you do NOT have to set ANY additional browse or source directories AT ALL to unpack the game completly! i don’t know why this has not been updated in the guide. you SIMPLY JUST have to fill in the working, build and tools directory correctly → i.e. for me it is for ALL 3: “D:\SteamLibrary\steamapps\common\Grim Dawn”, nothing more to do, then simply extract it from that folder, it WILL unpack everything, also GDX1 + GDX2.
If you want then IMPORT anything you do NOT click the “Database - Import Record” function AT ALL! Never do this as it might destroy your modstructure… Simply right click your mouse to the destination in your mod and choose “Import…” there you can even import files from ANY storage location on your computer and you are not bound to the basegame database structure at all,…
In addition IF you want to have it cleaned up for yourself, make a folder on desktop, name it “DESKTOPSTRUCTURE” → copy ALL files the AM unpacked here, start with basegame and copy THEN over gdx1 + gdx2 in that order to have a complete basegame structure image for your own, from which you can also always import with ease.

1 Like

Modding Guides by Elfe are now wiki posts and can be edited (I’ve made a backup just in case).
Elfe also changed the order of directories as recommended here

1 Like

OMG that did hahahaha
Thanks a lot, such a small detail let me stuck a whole week…

I finally did what you recommended in the past I believe which is cutting and pasting GDX1 working files over base game ones and then GDX2 files over it because I couldn’t get the right file to import regardless of whether GDX1 or GDXX was first :thinking: Also deleted addition source directories as they were no longer needed. Also this saves some space on a hard drive.