[REL] Grimarillion v90d

大概是你打包方式有問題,我用你的 .txt 文本重新打包就顯示中文了:text_zh.zip (427.9 KB)

我不會打包 我是上網一個什麼 怪怪的軟體打包的 不然一班都是怎麼打包呢?

難怪你做出來的.arc 不能用。 :wink:

正確方法是用遊戲自帶的編輯器 AssetManager.exe (簡稱 AM)來打包的,你可以自己查閱它的使用方法。


Making an hour a night for grim dawn and man got to say I love the way this mod matured. I have a lvl 96 wz + champ but meh she’s way to op so started a melee class as it requires a lot more skill. People cry over the evade mechanic. I agree, on the base game it’s not needed but with grimillion and a melee class you gotta be quick :grin:

Seeing as the upcoming update for GD will break this mod (and all other mods with modded inventory ui), I kinda had to push this out for you guys, it’s a smaller update than I wanted to do but …

if you’re not using, I’m not sure if this will cause issues… if it does then… just stick with v90c til then.

v90d Changelog
  • Fixed an issue where a few Zenith crafted items were still not generating Evoker affixes.
  • Fixed an issue where Shaman class combo tags were showing up as Arcanist ones.
  • Added 180 new affixes for Zenith helmets, belts and amulets. This is among all levels though, the actual amount for each level group is only 36, which is 6 affixes for 6 classes. The reason for this addition was to add a plethora of conversion options for Zenith classes. (this conversion only works on Zenith classes)
  • Updated some world map files… let me know if there’s weirdness going on cause I’ll have to revert this.
  • Fixed an old issue with certain shattered realm zones that were blacklisted because enemies refused to spawn in those zones. The zones now work and have been re-added.
  • Fixed an issue caused by GD update, causing items to crash the game if moved around your inventory.


Updated the Rainbow File for v90d.

Hoping for some assistance with getting rainbow to work correctly:

I have v90d installed and the updated rainbow file for it. As you can see, colors don’t show for resists. I’ve deleted and reinstalled the mod, deleted and reinstalled the rainbow file, uninstalled/reinstalled GD entirely (I think). I’m at a loss as to get the resists back to color mode.

I do not have the supporter packs installed if that matters, nor have I fiddled with user data in any way (I don’t know where all of it is.)

Any help would be greatly appreciated.

grim some colors

Sorry, I seem to have put in the old normal text about the UI (tags_grimarillion_ui.txt). .

That did it. Tysm for the quick fix.

Edit: on the Priest and Crusader (my current classes), skills are showing different types of “tag not found,” namely tagCurrentLevelAugment and tagNextLevelAugment.

I don’t know what those are. Please show me the screenshots.


Rainbow Filter - update to the latest version.

I have the latest version

I have actually checked and there is no problem.
Looks like “tags_ui.txt” is not loaded. This file is included in the rainbow file and would normally be read.
Is there something in “Grim Dawn\settings” that you are adding to it?


I haven’t altered anything. I ran a file verification and that checked out. I am also seeing the same issue with skill trees in vanilla GD.

Edit: this what you’re referring to?

Yes. If you remove it, it will probably display correctly.

If “text_en” is provided in “settings”, files with the same name will take precedence over it and the others will not be loaded. Therefore, it should be renamed as “text_en_temp” (e.g.) and the “text_en” should be removed.

Removing the file fixed it, however, there’s a new issue:

This is only happening in grimarillion.

Edit: fixed that by deleting the renamed original text_en.arc file.

Ty for all the help @Matougi

Any chance of a few more pistols/crossbows with Outrider skills on them. There seems to be exactly one pistol.

And two crossbows.


Nothing lower level at all.

Plenty of lower level stuff, you just won’t find it in GDStash. Talk to the Incarnate.