Skelly Stance Selector

Skellies need a stance selector. Like familiar, hellhound or blight fiend, you can set them to defensive or aggressive but not skellies. They just tend to be neutral. End result is your blight fiend is fighting the big boss while your skellies are sitting around having dinner with you while you heal …

I get non-permanent pets like marrow band or reap spirit not getting one, but skellies need a bar in the top left all to themselves!!!

Apart from that skellies are great. A big part of why I like GD so much :slight_smile:


Btw can this be modded? Has anyone checked it out?

1 Like

Not sure, drives me crazy!

Yes, you need to change skeleton controller values :slight_smile:
Seems very easy actually. I can make you a quick hard mod I think.
I’ll just unpack game because I’m not sure if I’ve done it already.

1 Like

think it has been brought up before,
and imo it would be nice for all pets without an icon/selector, if not just defaulting them/all pets to aggressive
reap spirit/wraith, blade spirit and even empybros etc feel like they could benefit from having a “whip the slave” mode
nemesis gets rawr mode/icon switcher, but so many don’t, and would be awesome to have the extra “leash” from aggressive

and if possible, “somehow”(maybe dreaming), to even have separate skele stance modes, so you get differentiate between the melees and ranged bones ? :ok_hand:

1 Like
1 Like

I’m pretty sure all pets without a “pet bar” have “aggresive” by default.

1 Like

OP saying skellies are too calm / there more posts like this / just modded pet to aggressive
and seen all the numbers yet you’re pretty sure they are aggressive by default? :slight_smile:
The file has even normal in name, other pets have normal, aggressive and the other one.


Pretty sure they are on “normal”/“standard” (whatever it’s called). I’ve noticed the same behaviour when I killed ravager on skeleton cabalist. When you disengage a bit you can have hellhound & blight fiend still tank ravager while skellies chill around your char doing nothing. This is currently the reason why I don’t put other pets to aggressive anymore while playing a skeleton build, they’d just end up tanking for nothing.


I even made a screenshot because I wanted to say to OP that modding skeletons is not possible
since they only have normal controller but then I just looked at the controller and noiced it can be
changed easily so I forgot about this screenshot:

You can see skeletons and skeleton casters have only normal controllers and numbers are similar
to normal hellhounds. That’s why I modified them to be like aggressive hellhounds.


pretty sure i 100% saw a (if not multiple posts) incl from Maya, complaining about it/confirming they were not aggressive, and multiple issues arose from it, ex like Protoss mentions


The barking is just an added bonus.


Instructions unclear. These are my skeletons now:


Can confirm the moment I run even a bit from the mob, those skelly horde immediately disengage unlike aggressive Hellhound.


This probably depends on what one considers “aggro range”. Here’s a post from Evil_Baka:

I personally didn’t encounter much problems with skeletons range. Maybe their range is a bit lower, but I wonder if it has something to do with a size of a pet model.

1 Like

They have the same numbers as others pets switched to normal, well at least hellhounds which I checked.
OP just wants to be able to switch them to aggressive for more consistent behavior among his pets,
because he prefers aggressive mode. So do I, I even wrote AHK script that toggles pets to aggressive,
because this clicking every time you start the game is pretty tedious.


Well, I’m not tampering with game files so I wouldn’t know the numbers. But if memory serves me, I’ve seen the discussion of temporary pets having “poor aggro range” and I guess Z said they have “aggressive” by default. So I figured it would only make sense if skeletons had the same going on.

Can’t find the topic though =\ Also not 100% sure if Zantai was saying something about the matter either. My memory is kinda shit. Well, at least I know what kind of testing I’m gonna do tomorrow…

So I did a simple and short test by summoning some pets, walking out of DC and taking baby steps to pinpoint the range at which they aggro. Tested on Skeletal Servant, Hellhound and, of course, regular skeletons. Servant and Hellhound were set to “aggressive”, obviously.

And… results are unsirprising: aggro range of all pets in question seems to be pretty much the same. I made three recordings to capture the moments at which pets become aggroed, and here’s what I’ve got:

So here’s that. I’m not sure why some people have problems with skeletons “chilling” if their range is ± the same. Don’t forget they have some kind of “encircling formation” around the player:

As you can see, the distance between those two outermost skeletons is quite significant (can squeeze 2-3 skeletons between them), so it’s no wonder the ones at the front will aggro and the ones at the back will not.

Also keep in mind the size of pet models. Bigger ones can stand at the same distance as small ones, but since their model is biger, they are closer to mobs and can trigger faster. At least I think how it may happen.

I think it’s more complicated than the one number you’re trying to measure. Here you can see why skeletons are normal, the same as normal hellhounds and differ greatly from aggressive hellhounds. Skeleton casters are the same as normal skeleton. Difference in sizes was definitely not taken into account here. Values from controller_skeleton_normal.dbr that skeletons use, were just copied values from other normal pets. Honestly, not sure, why you bother to prove anything here. Some players just request behavior selector for skeletons and that’s about it. For sure it’s useful for other pets.

Here’s table with some values from the files. These are the files that govern appropriate pets behaviors.

parameter skeletons normal hellhounds aggressive hellhounds
pursuitDistance 18.0 18.0 20.0
viewDistance 14.0 14.0 18.0
pathingViewDistance 14.0 14.0 18.0
fleeDistance 5.0 5.0 4.0
roamBehavior NeverRoam NeverRoam Roam

To be able to see images better, you need to

  • click one of the images to display in the in the middle
  • right click
  • select “View Image”
  • zoom


Because their range isn’t the same. Never was. Not sure what else to say on that.

1 Like