[Tool] GD Stash

If you have the latest version (1.7.3) it can load the GD 1.2.0 characters

Thanks, I was wary to change anything until I was sure.

Works fine! Thanks for the help. Off and on player since the Kickstarter, hate to lose that stash. I have been giving Diablo IV a try for a few months and realized I wasn’t enjoying as much as GD, so back I come! Lol.

Hello. Trying out the new 1.73 version on 1.2.0.1, I’ve imported the database, but get a bunch of warnings… And all my DLC material is gone! Like, Ugdenblooms and stuff. Gone! Are they gone for good? I forgot to make a backup, fool that I was…

Welcome to the forum. :slightly_smiling_face:

Latest GDStash version is 1.7.4

I looked at my installation, and it’s actually 1.74. I downloaded it literally an hour ago. Oops! Typo.

What do you mean gone? Did you store it in GDS or do you not see them in the GD shared stash within GDS?

If the DLC does not get imported, then GDS does not recognize that you have it installed, ie it is not found within the GD install directory.

Which startup screen does GDS show, vanilla GD, Malmouth or Forgotten Gods? Whichever one it shows is for the DLC it found, so that is what the import should give you

I am having a similar (or the same) issue as inconmaster when importing using 1.7.4.

My issue is that a lot of items are shown as invalid, and DLC items are not visible when looking at my stash (or any inventory) using GDStash.

I get the FG startup screen.

When running the DB import, it does go through both DLC databases, but after that step I get a lot of warnings of invalid items (same error I get when loading my stash in GDS).

Additionally, when I look at mastery info (or the char editor) the DLC masteries show as ???

TLDR; It seems like GDS correctly picks up the DLC (FG splash, and during import) but for some reason dlc items are not recognized.

I am on Linux, and running GDS using Java 21 if that might be the cause for this. I can see no errors in the command line when running the JAR.

I was able to fix my issue - but I did a few things at once - so I am not sure what fixed it.

  1. I changed the config in GDS to not have any localization file selected
  2. I updated group permissions recursively (to have +rw) for everything in the GD save, and game directories, as well as +X (so set executable and search permissions for all the files).

I suspect it is the localization file, so I think it might be worth trying that first if someone is having the same issue.

I recently reinstalled GD Stash on a new computer and though I entered the save directectory as instructed for cloud saves the program gets the old stash data from my OneDrive. This data is years old at this point. I expect I can fix this by switching off cloud saves, perhaps deleting or renaming the OneDrive Directory, or start using the OneDrive with the new computer. I was surprised the program searches this first and thought I would meention it to others to see if there is another issue I should worry about.

Thank you for any replies and the program

the program looks in the save directory you specify, nowhere else…

You are correct. When I tried just renaming out the OneDrive Grim Dawn file, my current stash was seen. I also tried to adjust the settings and the Grim Dawn folder was recreated by the game on the OneDrive which contained this. I expect this is an effect of using cloud saves. Anyway, thanks for your rapid response.

Disable/uninstall OneDrive, it’s a menace for hi-jacking the My Documents folder.

Version 1.7.4 released, some additional compatibility changes for GD 1.2.0 (most importantly the localization)

A little late, apparently I posted this in the wrong thread :wink:

1 Like

I just downloaded version 1.7.4 and when I try to import the stash from the save, I get quite a few errors and warnings.


Is there something else I have to do before using it?

nothing else should be necessary, it looks like GD Stash only imported vanilla however, not the DLCs. You should be able to see this during the import steps. Also, the loading screen if GD Stash differs, based on which DLC it found / did not find, so if it finds no expansions you should get the red vanilla screen.

As to health and mana potions, they no longer exist, so that part is ok

It seems the Stash managed to see until Forgotten Gods?

I tried deselecting the localization as well but nothing changed…

yes, it detected FG, which also means it will import the expansions (it found them after all).

So even when not specifying a localization file, .zip or .arc, the issue persists? That is weird, try importing again and check that you see messages about it loading Forgotten Gods data


Now it seems to be working?

Thanks for the help

Hello!

I can not see all sets in ‘Crafting → Search → Sets’. Everything above level 75 seems to be corrupted. Any idea why? I have the latest GDStash and Java.
gdstash