[Tool] Grim Dawn Item Assistant


No, that is not what I asked. I know about that.
Vanilla and Vanilla(HC) are 2 separate databases. My question is if I can merge the two of them, so all the items can be in Vanilla(HC). Yes, I can transfer them from IA Vanilla into my stash and then send them back to IA Vanilla(HC) using the last tab, but I have hundreds of items. So again, can I just do this process other than manually?

How do i download this ?

If I’m not mistaken there is a toggle button somewhere in the settings page that allows you to share the two. I could be misremembering but not at computer right now.

Same way you download and install anything else.

1 Like

So today once again I encounter this problem, I started the Item Assistant and nothing happen, I check at task manager it show that the Item Assistant suddenly closed itself without prompting anything. Download and installing the latest update also wont help.

But, the trick to start the assistant in older version still work, once the older version has started and minimized to taskbar and then launch the latest version, It work again. But starting directly from the latest version will not work.

Any ideas to fix this issue? What I remember from what happening in the past and yesterday is before the day it happen there is a power outage in my area, and the Item Assistant is running when it happen.

Try installing IA in a new location (a different folder)

If that doesn’t solve it, my best guess is that you got an anti-virus issue, blocking the newer version of IA.

Failing that… check the log files. If IA was able to start at all, it will have logged what happened.

Already tried that, no antivirus are active. The latest version of IA not starting at all, meanwhile the older version can and not showing anything strange on log files

I recently experience a bug after my Pc crashed. When I try to open the Item Assistant it appears in background processes for like 1 second and then just vanishes instead of opening.

Someone help please, I tried uninstalling and restarting Pc a dozen times already, it just wont work.

Edit: I just noticed the guy above me has the same issue

Hi all! I started a few days ago using Item Assistant and I must admit it’s a great tool for this game. The only thing is that I experience the following issue. Every now and then I go at the backup tab, where my onedrive is selected, and click backup now. I check my items later on and some of them have the cloud mark on them normally while others have the cloud with the red cross on it. No matter how many times I click the “backup now” button some items seem not to get backed up. Why is this happening? Any help is greatly appreciated! Thank you in advance!

Seems like we got same problem, my current workaround is using the old version of IA. I use the 1.2.7042.33910 version, you can get it on nexusmod, here is the link.

This looks like an absolutely awesome tool! Thank you!

I have noticed one issue, though, in my first day of using it … I can understand not making every last potential item attribute directly searchable/filterable, as that could make for a very clunky, cluttered interface. However, it seems as though certain attributes aren’t even displayed on the item “card” within GDIA.

For example, I stored a pair of boots with 21% Life Leech Resistance, and another pair with 27% reduced stun duration. These aren’t attributes I can search on, from what I can see – if I’m wrong on that, please let me know! But the larger issue I see is that these attributes don’t even show up in the information that GDIA displays about the item. The attributes are there when I check the items back out, but if I didn’t already “know” these were the particular boots with those attributes, GDIA wasn’t going to tell me.

I can see that becoming a bit more of a problem later on if/when I have a really full database of stuff.

Is there any way of at least making sure all the item details are displayed in GDIA, even if they aren’t all directly searchable?

Also, on that last front, as I am still fairly new to the game, with only a few toons in the works so far, it seems like there may well yet more item attributes like these that I haven’t even seen, or at least haven’t paid attention to, as yet. I can see where it could be a nightmare to try to represent all the possibilities in a search interface and still keep the UI clean and easy to use. But if you wanted to try to make these kinds of things more generically searchable, would it be at all possible to do it via a second text input field? If I could type in, for example, that I’m looking for an item with “Life Leech Resist” in the attributes, or “Energy Regen” or pretty much any text matching a piece of an attribute description that isn’t already a choice on the search/filter screen? Just a thought, since ultimately, the ability to search/filter by any attribute at all would seem to be ideal …

Thanks again for a fantastic piece of work!

Some stats may be missing, if you got a list, create an issue on github and ill get to it.

As for free text search on items, it’s definitely on my TODO list for future functionality. Not a huge priority though, are a few other issues that needs to be looked into before new features is a priority.

Patch notes 1.2.7240.25671: Fixed an issue some user(s) were experiencing while starting IA.

The red X cloud just means that its not using the IA online backups. Not really anything to worry about if you’ve chosen not to use it.

I should probably remove the clouds for those that’ve selected “I opt out of online backups” under settings.


I’m seeing something for the first time that I haven’t noticed before.

In the status bar at the bottom it says “Could not find the Grim Dawn Install location”

The logs show that my Steam location is fine but it keeps debugging and looking for the GOG install location.

I seem to have no problems accessing stuff so this isn’t a functionally issue but just wanted to check if this is as intended?

EDIT: Never mind I’m an idiot. Realized I was looking at it without having the game actually running.

I know I am quite late for a feature request now in respect to the lifecycle of Grim Dawn but I am new to the party. And maybe I am using IA wrong. Right now I am dumping every rare+ into IA. Since I am a new player I don’t know which rares are effectively useless and which ones may be fantastic for another build.

But I can guess that about 99% of the rares are only good for selling. Now I only need a way of identifying those (or the other 1%) quickly.

So I would really love a feature in IA which allows for filtering for (somewhat) matching affixes on items. Like when a weapon has a rare prefix for a certain damage bonus and a corresponding magic suffix for the same damage type.

Seeing that this might be too much to ask for (and to maintain, when affixes get reworked) I would like to use boolean operators on filter criteria. So instead of always using an implicit AND on all selected filters, I want to be able to use a filter criteria as an alternative for a another one. So that an item shows up if it fulfils one of the selected filters.

Last but not least I want to be able to negate a search, so I get all items that don’t match the query I built with the filters. This might help identifying junk for selling.

I’m having a recent issue. occasionally GDIA will not recognize items in stash and will not remove and add to DB. i’m not sure what makes items fit this description, sometimes it is a single item a group, sometimes it is the entire tab i just loaded. If i restart those items seems tagged in someway, i can transfer to other characters, drop on the ground, etc, and it knows not to collect those items, but others it will take even when in the stash with other items it does not. Ive tried searching for deposit issues and didn’t see anything that fit, sorry if duplicate.

You’re probably not running a dual monitor setup, and don’t see the duplicate message.
Go to settings and check “Delete bugged duplicates”.

Pete, you are a genius and I thank you.

1 Like