[Tool] Grim Internals

No, v1.100 works fine with the GOG version.

That is strange; I just tested it and I can’t replicate your issue!
Is GI working when you start it the normal way (without using the crucible shortcut)?

:slight_smile: I’m glad you like it!


Really? I haven’t noticed that! Thanks, I’ll have a look what’s going on.

1 Like

How do I configure how long the damage is shown for under “Incoming DPS”? By the time I look over to see what is killing me it is back to 0 again :frowning:



You cannot set how long the incoming damage is shown; only the current damage, the damage in the past second and the highest damage received in this game session is shown.

The incoming damage indicator could help to determine the weakness of your equipment; so if you look at the highest peak of the various damage types (the values inside the square brackets), you will learn what to improve.

I’ve been planning on making the DPS display better and more user-friendly for a long time now, but … I’m not very interested in Grim Dawn anymore; maybe my interest come back next year.

Edit: I remember there was a Grim Damage Tool (made by @slipperypete) available. I don’t know if it is still functional, but you could search for it.

Grim Internals (x64) v1.100a for GD Patch v1.1.9.3
Download-Link (MEGA)
Download-Link (Google Drive)

v1.100a (small hotfix)

  • Fixed an issue where the health/energy potions cooldown timer were visible in the Devotion window.

Known issue:


nize one :]

1 Like

Nexus / Site (I have no idea which version is the latest)

No longer being maintained, but should fully function on 32bit.
No 64bit support.

Site link will die/404 in roughly 3 months. Completely abandoned project. :slight_smile:

Hi, I genuinely absolutely love your work. That turtle completely made my day. They should be everywhere imo. Wildlife all over would be perfect.

I’m still getting the crucible error. It did work previously, and I use Grim UI X-Storage, with some custom files from @JMD such as a custom survival2 file (I removed that). Otherwise my items seemed to glitch in the mod and I can’t place them. JMD put a lot of work in for me to get crucible working, but now I get a black screen.

It’s just that with the bit white cursor!, it’s genuinely mortifying! My character was there the first time, but then I chose crucible of the woods and after the black screen, I can not select him at all.

Is this likely a problem with the new update and X-mod Storage being incompatible, especially with the custom files that I previously needed? I’ve completely restored crucible, Grim Internals is up to date, and my shortcut is:
Target: “C:\Program Files (x86)\GOG Galaxy\Games\Grim Dawn\GrimInternals64.exe” "/Mod:“Grim UI X-Mod”
Start in: “C:\Program Files (x86)\GOG Galaxy\Games\Grim Dawn”

Is that correct? Any help is appreciated. The only difference I can think of is that X-mod Storage does not work on this version, but I’ve struggled to get any X-Mod working when they used to be fine.

Any help is much appreciated, thanks. I just want crucible back!

Edit: It is closer to working with the shortcut “C:\Program Files (x86)\GOG Galaxy\Games\Grim Dawn\GrimInternals64.exe” “/Mod:Grim UI X-Mod” - and you can see the mod is recognised and activated in the top right.

I also set it int the Griminternals.ini file. I am now using the new v1.1.9.3 Grim UI X-Mod Strategiest and it is working perfectly in the main game/Grim Internals. Just not Grim internals Crucible. I feel so close when I see your mod active notification in the top left, and my character doesn’t dissapear when I select a crucible location from the drop down menu. It is nearly there; but again, black screen. This does/can work, I feel so close! Any help is massively appreciated. I am no longer using custom or outdated files.

Edit 3: UIninstalled Crucible, Tried new character, same black screen. However, I set it to windowed borderless and on the loading screen you could vaguely see the health bar before it crashed and created a crash dump report. I’m not sure if that will be helpful.grim Dawn Crash report 76fd82a4-f09f-40f0-baaf-1599749bfa0e.zip (34.3 KB)

I tested it again and again, but Grim UI X-Mod works just fine in Crucible mode…
(that’s what I wanted to reply again to you!)

…but then I realized that you have a custom mainmenu (AoM) background installed. I installed it too and yes; the game was crashing for me when I tried to start the Crucible Mode! :slight_smile: Yeah!

So, as a workaround, uninstall the AoM mainmenu background again.

I have to check, why this custom background is crashing the Crucible mode… could be interesting for me to find out.

Thanks for reporting this!


I’m sorry. Somehow I can’t view my mod characters for crucible mod. I tried to implement what you said. I could not do it.

The options I tried are; (Griminternals.ini and shortcut properties)

ModName="Grim UI X-Mod"

File target line "D:\Program Files (x86)\Steam\steamapps\common\Grim Dawn\GrimInternals64.exe" /Mod:"Grim UI X-Mod"
ModName="Grim UI X-Mod"

File target line "D:\Program Files (x86)\Steam\steamapps\common\Grim Dawn\GrimInternals64.exe" "/Mod:Grim UI X-Mod"
ModName=Grim UI X-Mod

File target line "D:\Program Files (x86)\Steam\steamapps\common\Grim Dawn\GrimInternals64.exe" /Mod:Grim UI X-Mod

There is no need to edit the GrimInternals.ini file; the launcher writes the value into the file.

This is the correct cmd line!

I did as you said but it doesn’t work. I didn’t make any changes to the game folder or mod.

Check your mod folder; is there a folder called “Grim UI X-Mod”?
If so, then I don’t know what’s going wrong! :thinking:


I wrote the folder name directly by copying it so that there is no problem.

Can you upload your GrimInternals.ini file? Perhaps there is something wrong.

Here it is GrimInternals.ini.zip (1.5 KB)

I’m sorry, but it’s working for me.
Does anyone have an idea what’s going wrong?

Looks like it’s working just fine for me…

You sure you inputting it in the shortcut’s Properties Target properly?


If the above shortcut modifier checks out you still might want to show us a screenshot inside the first level of the folder so we know its contents look as they should be.

1 Like

So, I found the issue that happens when using a custom main menu together with the Crucible mode. I will upload a hotfix tomorrow evening.