[Tool] Grim Internals

I haven’t encountered any bugs while playing. Everything looks good…


“We’re a go here flight” :+1:

No glitches, seems to be working fine… (Although I don’t really have the time to beta-test properly)


For some reason having problems starting GrimInternals. I started Steam after turning off cloud saving and installing the package to the Grim Dawn folder. It says VCOMP120.DLL not found. Can somebody solve my problem?

If it is not installed, you need to install ‘Visual C++ 2013’. If it is installed, you need to remove it from your computer and reinstall it.

If I want to change the color of the blood bar value, what should I do?
What I mean is, I want the color of the value not to change based on percentages, but to use a single color, for example, the player has a green value, and the monster has a red value. This looks very clear.
Thank you!

Grim Internals (x64) v1.102 for GD Patch v1.1.9.3
Download-Link (MEGA)
Download-Link (Google Drive)


  • increased the compatibility of custom mods with extended inventory/stash sizes for the Crucible Mode.
  • added a warning message when trying to launch a mod with an unsupported language (ex.: Launching the RoT Mod, but have the DoM language file selected, result most likely in a corrupted save file.)

Known issue:


Please read the section in the Q&A about how to setup the health bars.

Sorry I didn’t make it clear, what I want to change is the font color. I have changed the health bar to a single color, but I have not found a way to modify the numerical font color. I hope the two can be consistent.

If i recall you cant set the color of the font to a particular color. It works the same as the healthbar colors. (3 or four)
If you go low on health it goes red for example
Most healthbar issues help is covered in the Q&A if i remember well

I hope there is a way to make the font color and the color of the health bar consistent. For example, I want the player to have a green health bar and value, and the monsters to have a red health bar and value. They don’t need to change the color based on the percentage.
Anyway, thanks for your reply.

1 Like

Grim Internals (x64) v1.103 for GD Patch v1.1.9.3
Download-Link (MEGA)
Download-Link (Google Drive)


  • Added 1 new entry to the GrimInternals.ini file:

    When set to “true”, the player’s health bars/stats are displayed in green,
    while the health bars/stats of monsters are displayed in red color.

Known issue:

This is the last GI patch for this year! :zzz: :smiley:


Im sure I say this for all of us. Enjoy your rest. You are the best as always.

I didn’t expect it to be updated so soon, you’re the best! ::

I have tried everything and I can’t get my character to show up when launching using griminternals.exe

I’m running windows 10 x86 and notice there is only an x64 version. I don’t know a ton about that or setting up mods, but I tried for probably a good hour. What am I doing wrong? Is that the issue?

  1. Backed up my save and saved it to my desktop.
  2. Turn off cloud saves in-game options.
  3. Extract GI to the “grim dawn” folder under steam/steamapps/common.
  4. Delete “saves” folder
  5. Extract back up save to the “grim dawn” folder mentioned in step 3.

I have a level 66 and I’m new to grim dawn and obviously dont want to have to make a new character just to use this mod. Hopefully someone can help. Thanks in advance.

Извините за то что беспокою, но я не знаю куда ещё можно написать😔 подскажите, пожалуйста, где можно скачать эту программу на прошлую версию Grim Dawn. Я просто играю на старой версии, а обновить не могу, потому что много персонажей прокачанных , а ники у всех на русском языке😔

Добро пожаловать на форум. :slightly_smiling_face:

Вы не можете, вам нужно обновить игру до последней версии Обновление игры не повредит вашим персонажам.

Local save folders go in this location…

C:\Users\YOUR USERNAME HERE\Documents\My Games\Grim Dawn\save\main

1 Like

*When I say zip I probably mean .7z which is a 7-zip file.

I am level 68 and have had problems, so can only try and help to my best. Feel free to ask any questions and look to get a resolution. I also had the dissapearing character and it was due to my custom character mod/map being incorrect or grim internals installed incorrectly.

First off I backup Grim Dawn using 7-zip and right clicking my main folders in program files (for game backup) and documents (for save backup). I right click - 7-zip - add to archive. If I have problems I delete the folder and click ‘extract here’ with 7-zip.

I 7-zip: C:\Program Files (x86)\GOG Galaxy\Games\Grim Dawn

I 7z-ip My character etc which is in: C:\users%username%\Documents\My Games\Grim Dawn

(my custom charcter goes in \save in the above directory).

This is because it is a custom character so I can use mods. Main campaign = no mods and possibly no Grim Internals? I think. No crucible fix though, correct anyone? Why are you saving to main if you are modding? That might be your problem but I’m using GOG and not 100%.

Main campain characters for me: C:\users%username%\Documents\My Games\Grim Dawn\main

I think I simply cut and pasted the character and files from that mod into:

Custom game: C:\users%username%\Documents\My Games\Grim Dawn\save

My game folder, where Grim Internals goes, is in:

C:\Program Files (x86)\GOG Galaxy\Games\Grim Dawn

I run Grim Dawn as admin from: C:\Program Files (x86)\GOG Galaxy\Games\Grim Dawn\X64 and run Grim Dawn.exe as admin. This launches x64 as admin. I’ve had errors if I didn’t at least once or every now and then.

I paste the latest Grim Internals .zip to C:\Program Files (x86)\GOG Galaxy\Games\Grim Dawn and click 7-zip > extract here on the file.

I launch it via the shortcut via the startmenu shortcut after first launch or C:\Program Files (x86)\GOG Galaxy\Games\Grim Dawn\GrimInternals64.exe

After the first time I launch I choose custom character and mine is there, as I have them in save. I then, in game, press ctrl + F5 to load the GrimUI settings and alter to my liking. Then close GrimUI settings and log out.

I also had the checkmark “mod” enabled in the charcter/item mod GD Stash in the character screen, then click save. I’ve got no idea if this effects things with the mod I use. You might have to import the database or something too, I’m unsure. There are help documents.

I use:

C:\Program Files (x86)\GOG Galaxy\Games\Grim Dawn\mods to place the folder Grim UI X-Mod. You then see it on the custom character loading screen and can change between mods (dangerous). I personally use the X-Mod Strategist mod from [REL] Grim UI

I’ve got no idea which mod you’re using, Grim Internals might not require all of this as its just a very simple zip ( :grinning_face_with_smiling_eyes:) which hooks into the game to do something very magical.

But most other mods are placed in mods and to my knowledge require the extra work I’ve explained. The Grim UI X-Mod folder contains folders called database and resources and .arz and .arc files.

Make sure you right click and extact here for grim internals so you see C:\Program Files (x86)\GOG Galaxy\Games\Grim Dawn_GrimInternalsData and not C:\Program Files (x86)\GOG Galaxy\Games\Grim Dawn\Grim Internals V 1.03 or whatever_GrimInternalsData

Grim Internals data goes in the game folder.

Any problems? Fiddle round, or use the back up zips. Make sure you don’t delete the zips.

The shortcut for my x-mods crucible fix is attached in a zip, simply because a few people couldn’t make it work. Alter the shortcut in properties carefully for your chosen mod. And use a custom char, to my knowledge. Edited because it appears zipping my shortcut turns it into an exe file??? Apologies.

Which mod are you trying to use?

@GlockenGerda - is it normal to have a folder C:\Program Files (x86)\GOG Galaxy\Games\Grim Dawn\GrimInternals64

Containing .data .rsrc etc? I’ve never noticed it before.

1 Like

I dont have GoG version but, the GrimInternals64 folder you have must have been a leftover from old versions right when Glocky started making it easier for us to add things overriding the base game files

1 Like

Am I supposed to make all those folders? My documents in the area you are describing are empty