[DAIL] Bugs

I am now poofed so hiding thread content

This thread is for releases of dail.

more text coming soon.

other threads will be


try and keep discussion out of here. and instead . go to DAIL DISCUSSION

also. occasionally Kathanious and others will put up

[DAIL POLL] - something

go in there to voice your opinoion.

lets truly make this a community effort.

also dont post anyhting in here until ive made a few placeholder replies of my own.

why is it lowercase?? for the title that is

oh well

Attachment: 20160907185334_1.jpg
Attachment: broken masteries window.jpg
Attachment: screenshot01.jpg
Attachment: screenshot02.jpg
Attachment: screenshot00.jpg
Attachment: mw03.jpg
Attachment: mw04.jpg
Attachment: dailfail.jpg
Attachment: StoneGuardian.jpg
Attachment: ChaosVortex.jpg
Attachment: Rhowari Legacy bug.jpg
Attachment: Ranger.jpg
Attachment: Terror Knight.jpg
Attachment: Tag Not Found items.jpg
Attachment: sentinel T-pos.jpg
Attachment: Peleus Ashen Spear.jpg
Attachment: DIAL Bug.jpg
Attachment: Bug 3-28.jpg
Attachment: BP.png
Attachment: tab02.jpg
Attachment: tab01.jpg
Attachment: MysticWarrior_01.jpg
Attachment: MW_title.jpg
Attachment: grim dawn 2017-04-30 20-52-07-70.jpg
Attachment: grim dawn 2017-04-30 20-52-12-98.jpg
Attachment: db20a483-3007-4c7f-b1cd-befcfad5d971.zip
Attachment: DxDiag.txt
Attachment: unsold 01.jpg
Attachment: tagmissing 01.jpg
Attachment: 60.9C icon errors.jpg
Attachment: Planes-Shifters-Equipment.jpg
Attachment: Tagnotfound-item.jpg
Attachment: add_tagname.jpg
Attachment: Text_EN.zip

This thread is for the reporting of bugs in the [DAIL] mod compilation.

Other threads are:

[DAIL] Release for release details, features, and credits to the assimilated mods.

[DAIL] Discussion for questions, comments, polls, and other related material.

To see a list of bugs and current items I am working on, visit the DAIL Nexus page.

i asked kathanious to take 2nd spot in every one of my new threads. if he ever does take over. deleting the content of the first post is close enoguh to bupming the 2nd post to the top

also this is me reserving the 3rd spot

is it me or a bunch of Frost knight skills are messed up… like Cold steel and Frost Aura doesnt seem to be working as intended

Charm of Water in Priestess does not work; it says it’s a buff, but it’s set as an attack skill which does nothing.

And in Necromancer tree, Bone Graft does not increase skeleton stats at all; supposed to increase their damage, health, energy, etc, but there is no change.

One other thing I noticed is within the Cenobite tree; the skill Chosen One is supposed to reduce level requirements for items by a flat amount, but hovering over items with a level requirements says “Level # Required (-#% - Chosen One)”. So, it’s reducing it by a percentage rather than a flat amount, as indicated by the skill. This could, of course, just be a typo on the skill itself and is supposed to be a percentage, but either way the skill description or effect would have to be altered just a tad. :slight_smile:

Hi all i think there might be a bug on the Fanshi mastery… the mastery itself if find but the name is messed up

Speaking of Cenobite, Shield Bash (the first skill which replaces default attack) has an invalid description and makes DPS look way less than it actually is. This is probably because DPS follows the description of the skill and counts every 4th hit as the “Shield bash” instead of every 2nd.

Still speaking of Cenobite, I cannot tell if the skill Encourage, the enhanced node connected to Sword And Shield, is working or not; it says there’s a 100% chance to use Boost Morale when Sword and Shield procs, but there’s no buff icon showing above the health bar to indicate it is working. I see enemies take the stated damage, but I don’t believe the buff is actually being received.

Fixed in next release.

Fixed in next release.

Playing Elementalist + Arcanist on DAIL SX (v0054) and experienced some crazy bugs while casting spells from Ele mastery in a multiplayer game.

Video here:

In solo game it’s ok, however in a multiplayer game it executes multiple casts of that same spell within a single cast.

That’s pretty cool. I’ll push this to Zenith thread and see what Ceno thinks.

@RAM Do you host or join the sessions?

This was joined session since they didn’t see my game in the lobby.

I just installed 0055 (twice), and i have the “Maximum level reached” bug with all characters, even new ones.

I had that bug at some point with a previous DAIL version, and forgot how i got it fixed.

I even tried deleting/reinstalling database by steam, and then using the fix, but each time the bug is still there.

Basically, your characters aren’t gaining xp? I’ll check changelogs and ask Davood if he recalls this issue.

Thanks for your report.

Masteries window seems broken, your screenshot indicated we shouldn’t be seeing the “extra” mastery slots anymore, and the buttons are larger than they show. In this screenshot my mouse was over Void Caller and you can see it highlighted, but Dream is also highlighted and what is being shown in the center. If I click, Dream ends up being the one that is picked. Because of this wonkiness it’s actually possible to pick the same mastery twice, though this does nothing but waste your second mastery slot forever unless you’ve put in no skill points at all.

I can confirm the max level reached bug with new characters, xp bar shows as maxed and thus can’t get any xp to level more.

Love that Frost Knight and Druid are now in proper working order! Unfortunately, I can also confirm here that Void Caller and Demon Hunter do not seem to be. If you do manage to select them through the currently screwy selection window, they have no skills shown at all and tag not found errors for the names once selected. You can put points into their mastery bar, but the bar doesn’t show up if you do.

Fangshi shows Coronus once selected, and Cenobite shows Fangshi once selected. In addition, Coronus mastery is listed in the middle of the cftx masteries (pretty obvious when you see the one purple name in a bunch of yellows) and Cenobite seems to be located where Coronus should be (the one yellow name surrounded by purple names).

Engineer mastery is completely busted now instead of just 3 of the combo end skills. All the skill boxes/circles are empty with a red X including the mastery bar button, so no skill points can be spent in it even if you were to guess on what the skill were. In fact, you can’t even undo the selection of the mastery now.

I checked this with the LITE installer, B Mode.

So there seems to be some issue getting my good working copy to the players. Here’s a sort of break down:

My local working (everything looks great and test plays) gets synced into another copy of everything we’ll call local/git. This copy then gets synced into my fork at git.com/Kath. From there I do a pull request and push it to Davood’s copy (the master). He merges it. Then syncs it to his local/git, then syncs again to his local working. From there he works his magic to package it up. Then sends the package to nexus (which reportedly has its own flaws), then downloaded by the player.

So any where in this process things could get borked. Davood and I will get this worked out and into your hands.

Almost assuredly to do with git. People love to espouse because it’s free software, but I find it an unintuitive mess that created more problems than it solved at my old work. Rebase issues galore!

Yes, the xp bar is filled up, and you dont gain xp, thus can’t lvl up.
Moving themouse cursor over the bar says “Maximum level reached”

It does that to all my characters, whatever their lvls, and to brand new created ones too.