Grimtools suffixes

Has somebody also noticed that some suffixes are not showing in grimtools on rares? For example of readiness doesn’t show up to me when selected on the item.

Works fine for me

Edit: of readiness is not a rare affix, that could be your problem

I have it on alex pants and on iron maidens shoulders and it doesnt show. You have to save it and view in the build’s main page. Then it does not show up. Or even if you upload the char from your disk then it still does not show up. Even when in game I have it 100 %.

Works fine for me. Tried Aleksander’s Chausses and it shows readiness suffix.

Also, like Snazz said, it’s a magic affix. You need to have magic turned on for it to show on the list.

Try it on this build’s shoulders.
Does not work for me.

After trying again, it doesn’t seem to work on some nemesis MI’s sometimes. No idea why

1 Like

GT is treating the Nemeses MIs like the faction belts, which can only have one affix. Tried adding Tempest of Readiness to a bunch of Nemeses MIs and only gives one of them.

1 Like

Let’s hope it gets fixed. I don’t want to redo every link in my builds :smiley: Is there some way to report bugs in GT?

Report it in [GrimTools] Item Database

1 Like

Suffix of readiness doesn’t show on pulsing shard as well. It is not even selectable now. Before new patch it was. Looks like it has been removed. GD stash doesn’t show it either. But on the other items it is possible to get but is not shown anyway.

Of the dranghoul on Kaisan amulet doesn’t show also and on Grava pants as well. It is still an available option. Other suffixes have problems as well.

Yes, indeed - as of v1170 is does not roll on weapon slots anymore.

1 Like

It is a really good suffix it could be brought back.

It didn’t roll on weapons past like level 20, this was simply cleaning up affix tables at all levels.

I actually use it on offhands on some of my builds. Is it possible to bring it back in full up to level 94? Or should I try to change them?

What about “of Nature’s Bounty”? Doesn’t show on my pants anymore…(Kubacapra Pants).

It hasn’t been available past level 20 for years, so if you used it in builds…

In-game? or in GT?

Yeah GDstash I know. I will change it then. Hard to know which ones drop and which don’t from GDstash. It isn’t a big deal anyway.


In-game everything is fine.