Half of city buildings "need repair" and are on 33% - v0.7.2

Not sure if I missed something, but I was working on my farm off-screen and when I returned to my city I saw this. Not sure if I missed a notification of a meteor shower or something, but since I don’t know what happened, I figured might as well post it here incase it’s a bug.

Not a bug, just the way it works. If you have enough labourers/builders they’ll get around to repairing those.

I have an update though.
They indeed started repairing the buildings, but some of the buildings are not being updated and remain on 33% health.

Also, the bug is the fact that they are all exactly 33% health with no real explanation on why this happens.

It also happened again on several structures that already were repaired.


10 chars

This school building is repaired, but at the same time, not repaired?

Well, no, it’s showing 33% in both places. Do you have enough labourers and builders to do repairs?

I mean, the “heath bar” doesn’t match left and right.
Also, the building was completely repaired, after reloading the save file the 33% bug disappeared.

But it still happens randomly.
On this screenshot, you see my farm to the right, which I checked for like 5 seconds.
After these 5 seconds I moved my screen back to my city and AGAIN a building is 33% repaired while it was completely fine 6 seconds ago.

Very weird.

Yep, only happens when I’m not actively looking at the buildings.

And after saving the game and loading the same file:

Im having the same bug. Was desperately looking for a repair button because it was showing in game that my buildings where condemned. Then after saving and reloading it was all repaired.

1 Like

I have the same issue. It seems like a prioritization issue to me. I posted in in feedback here:

1 Like

Saw the same issue.
Went unrepaired for 5+ years.

A couple reloads fixed it though.

Having a similar issue, buildings arent getting repaired (ever) despite having an abundance of resources and over 100 laborers available for tasks. My only solution at this point is demolishing and rebuilding from scratch, reloading doesn’t seem to fix it.

This really needs a prioritise button, absolutely busted and driving me nuts.

If someone has a case of this (buildings not being repaired) that they think is a bug, upload the .sav and associated .map file so we can see if it’s a legit bug or something else.

Saves are located in:
C:\Users\USERNAME\Documents\my games\Farthest Frontier\Save


I just updated to latest version, I know it’s not in the bug fixes but I’ll see if I can get you the save file when it occurs again.

Here’s a save file where the buildings stay on 33% after having reloaded the save.
On the left, it’s almost complete, on the tooltip, it’s 33% and on the right it’s also 33%.

A reminder that the cause of the integrity being lowered to 33% is still unknown and therefor could also be a bug, not only the fact that these don’t get repaired.

I ran into this too, it was surprising but i quickly figured out it is building aging. and it taught me that i built too much too fast because i had like 20 buildsings all need maintenance at the same time

something like he wrote, as everything in this game, these things are tied to some kind of progress, most of the time its town center level but some other triggers as well. For structural integrity to start falling, you must be in level 2 town center and play some time. Currently it is really like that that due the triggering working same time on all buildings, this is avalanche type issue that very many buildings get this issue same time. You must have enough resources and workers to fix this, if you know and plan ahead its not a big thing, but it sure is very annoying.
I have also had issues that integrity is 33% (I think there are just 2 states), but it doesn’t show the bar for that building while it shows for others, also I have had that its fixed but workers still say not possible to work. Both issues dissappeared after some years without reload.

With the recent information above, I think I can say that the cause is this so called maintenance.
But, if this is written down anywhere, maybe it needs to be more clear because I didn’t know maintenance was a thing in the game.

So for this issue, the current bug is the fact that repair status isn’t updated correctly.

I think i saw a tooltip about buildings getting damaged in heavy weather, maybe that is a reason for the sudden repairs i and everyone else keeps getting.
As for a work-around, you can relocate the building needing repairs, and you can just put it back in the spot it was before. After being moved, its set to 100% health. (it’s probably not intended to be used like this, but its a god send for someone already lowish on resources)

1 Like