How do I slightly edit an Existing Mod

So I found a Mod I absolutely love in every way, except one. It makes the CD for Blood of Dreeg 60 seconds, which is insane, and makes my Zergmancer build completely non-functional. So, all I want to do is change this one tiny thing in the existing mod.

Progress I have made thus far:

  • Identified the exact file I need to “extract” or “uncompile”, it is an .arz file, we’ll call it ModName.arz.
  • Wasted a TON of time trying to get AssetManager to interact in any way with said file. It can see the mod, it can see the .arz file in the database tab. It cannot do anything with or to it at all.
  • Discovered Grimextract, which actually works, and allows me to extract the ModName.arz, yay!
  • Found the exact .dbr file I needed to edit
  • Wasted a TON of time trying to get DBREditor to work, much like AssetManager, it is completely non-functional and useless
  • Discovered DBR files can be edited with NotePad++ (D’oh!), made the change I wanted to make in under 2 seconds.

Now here’s where I’m stuck. I now have a folder called “Records” with all of the extracted files from ModName.arz. These records are now set how I want them. How the HELL do I turn this “Records” file and all it contains BACK INTO an .arz file so I can actually play using the changed mod?

I’ve fiddled with every god-damned command I can using AssetManager, with absolutely zero luck. I’ve put the “Records” folder into the same folder as ModName.arz, and Assetmanager then “sees” it when I select the mod, but I still cannot interact with it in any way. Telling AssetManager to Build with the mod selected either does nothing or breaks the mod, causing the custom game I run using the mod to function as a completely normal game, with all mod changes erased.

I’ve tried googling for a few hours on this, but have made little to no progress as about 90% of the existing links I get take me to a fun notice from Crate Entertainment that they have moved their forums to discourse.

I’m so close, I have the editted file I want to use, I have the whole rest of the mod already made by someone 1,000x better at modding than me, I just want to take my one tiny change and squeeze it back in there! Any help would be GREATLY appreciated!!!

[EDIT] I have discovered an additional way to not make any progress on this! So, if you put just the “Records” folder full of DBR’s into its own folder under the “mods” folder, then find that using AssetManager, you can use “build” to turn said records into an .arz! I got so excited, was this the solution I had been missing? Could I finally play the Mod I love with the one change it needed? NO! Of course not!
What a surprise. Instead, you get about 2,000 “could not find template” errors, and the .arz it spits out completely removes all changes the mod originally implemented if you use it as the basis for a custom game. So, still stuck at the same spot. I can extract everything and make the changes I want, I just can’t figure out how to put the guts back in without breaking the mod.

Thank you!

Edit: setting up Asset manager to work.

Here on how to use crate’s tool to extract .arz.

As for what you want to do, extracting the file and building all of them into .arz as a mod should work.

Another solution is to make a mod with only the files you want to change, since you have them already extracted. Make sure you maintain the same path to the files as the mod or it will not work.
1.Build your mod. Now you have an .arz for your mod, with the mod’s name.
2.Go to where that .arz got built and paste in the .arz from the mod you want to change. 3.Rename the .arz you pasted in to whatever you mod is called.
4.Build again. The files in the .arz got replaced with yours.
5.Restore the original name and past it back in from where you got it.

Stan, thanks for trying to help, your advice is a no go, issues below;

  1. Following the instructions on the extract .arz thread you linked, I get to the point where I enter the archivetool command to -database the relevant .arz. CMD hangs for a second, then just gives another prompt line. It does not actually do anything with the tool, even though I have confirmed the tool and .dll are present and functional, and I’m typing in the command line correctly. Literally nothing happens, the archivetool does nothing, and gives me no error message to work with to try to find out WHY it is doing nothing.

  2. Going the other route, where I use Grimextract to successfully extract the .arz because archivetools can’t, I now have a resource folder with the documents extracted to DBR form, where I can edit the one change I want to make, trying to enact your listed advice doesn’t work. If I put all of the resource files into a new mod folder and tell the mod to build via AssetManager, it builds an ARZ that is like 167KB (as opposed to the source ARZ which is 5MB), while giving hundreds of “cannot find template” errors as it is building. The resulting ARZ, when used as the basis of a custom game, changes nothing from the base game, and is in effect not a mod.

I have to assume from this that I am in some way failing your listed step of “build your mod”, as I’m sitting here, with a folder full of the changed DBRs I want to use in the exact same folder layout as an existing, working mod. But when I select said folder and tell AssetManager to “Build”, it fails spectacularly and creates an .ARZ that does literally nothing.

Is there no other option/program that will let me take a perfect, successfully extracted .ARZ and turn the resulting extracted folders back into an .ARZ? Because AssetManager is insanely unintuitive, not working, and none of the existing documentation I can find anywhere covers editing existing mods, only creating entirely new ones from scratch. I feel like other people making larger more expansive mods MUST be able to successfully make a practice build, see what works, then uncompile it and edit and rebuild right? How is there no clear instruction on that?

TL;DR I’m at the point where I have the files just the way I want them, all I want to do is turn them BACK into an .ARZ. AssetManager is failing spectacularly with no explanation/documentation as to WHY it is failing so horribly. Is there any other program/method to create an .ARZ?

Have you checked you the setting up Asset Manager link?

iirc extracting the game files will also extract the templates, so no more template not found errors

K, so what I’m starting to think based on that response is there is no actual way to JUST edit an existing mod. Instead, I have to go through the process of extracting the entire game and both expansions into an entirely separate and new mod, thereby creating a mod from scratch. Then I have to try to recreate the exact same changes the existing mod I like made, hoping I don’t forget/miss anything important or game-breaking. So at this point, I may as well have just made the entire mod myself without ever visiting Nexus Mods in the first place. That is absolutely insane. I give up at that, I don’t have the time or patience to learn how to write an entire mod, especially once that changes almost every aspect of the game, from scratch.

I’ll just post a comment on the mod’s comments thread begging the actual creator to make a version where Blood of Dreeg has a normal cooldown, and then hold my breath. I honestly could not comprehend that there is no way to edit an existing mod, you just have to start from complete scratch every single time. I have a whole new level of respect for anyone who mods this game.

Thanks for your help Stan, I didn’t expect the end answer to be as monumentally shitty as it is, but that’s life right?

Your entire problem with asset manager has been the template not found error. The only thing preventing you from building the mod with the changes you made. Extracting the game files will give you the templates.

You dont have to recreate anything. Extract the mod, put it in the mod folder, open with asset manager, edit the file, build and you are done.

Just did exactly what you listed, did not work. I fully extracted the entire game’s files (including the expansions by adding the additional folders). I then moved the mod into the newly created mods folder inside the working directory. Extracted the .arz’s contents. Edited the file I wanted to edit. Ran AssetManager, told it to “build” the mod again. What I get in result is a .ARZ which is smaller than the base .ARZ of the mod (3.5MB instead of 5MB). I also get the extracted files still left inside of the newly created mod’s Database->Records location. So I have the .ARZ, and a bunch of free floating files that should have been compiled INTO the .ARZ.

When I load into the custom game, the ONLY thing actually working is the change I made, it definitely shows Blood of Dreeg with its original cooldown. Everything else is broken. Items no longer have distinct colors for their names, everything is a uniform white. When I level up, I do not receive skill points. I also cannot assign the skill points I do have. The graphics of the skill tree are broken all to hell, with most of the connective lines missing, the mastery button is blank instead of having a colored plus sign. The list goes on.

The fact that I can get my change to go through, while somehow breaking everything else that I haven’t changed, has taken the last of the wind out of my sails. I am completely out of my depth, I have spent more time on trying to make this work than I have spent playing the actual game, I’ve tried so many different things that I can now no longer keep track of what I’ve already tried so I don’t just try it again. The best I can guess, maybe the original modder made a unique template or some other sort of unique file that made the mod work when compiled, but didn’t include that file in the mod itself, so I’m trying to finish a puzzle with 500 missing pieces and no picture to go off of.

My only major take from this is 1) Sending people to the “modding guide” pdf when they ask questions is a shitty thing to do, because that thing is straight up 100% useless and 2) Crate REALLY needs to work on getting all of the dead search results on Google removed. 90% of the links I tried to follow for the Crate forums were completely dead, which got more and more fun each time it happened.

Moving pass the template error was a big step, though I dont know what could be going wrong in the build,

If you got one attemp left, try my second sugestion from mu first post. That is how I have made small changes of GD’s files.
Read it carefully as does not involve recreating the mod. You create a mod with the files you want to change with the changes you want, build, swap .arz files, build again. If your files do not have the same path as they do in the mod, they will not get overwritten.

Edit: try using the forum’s search function. As to whats on google is not under crates control

No. You do have to extract the game files to get the templates, but they do not become part of your mod, nor do you need to create a new mod, you can use the existing mod.

Before you can compile that existing mod with your changes, you will need to extract the game files however, so the templates are available.

Assuming you have the vanilla files set up, the whole exercise (extract mod, find file to edit, edit file, compile mod) should be something like 5 minutes if you know what you are doing. Your problem is that you never did the first step of setting up AssetManager properly.

Hey, necroing is bad but this is a topic which I guess fits very nicely with what I am attempting, and I do not have to double-post similar threads.

I have been attempting to merge two mods (for personal use!), namely SimpleSmash’s slightly increased experience, loot and monster spawns with Grimarillion’s mod. I’ve attempted similar steps as the OP, namely extracting the .arz, and @Serious_Stan 's approach to build/copy/paste/build the mod. With the former, I got all necessary files but had no idea where to put them.

The latter one worked, apparently, up until it was time to play the game. Whenever I did, regardless of if it was with an old or new character, the character simply ran off, clipping through walls and disappearing in no time at the first movement.

Now, how could I fix this?

Thanks in advance!

@Io_Hd - Did you succeed? Actually you were trying to do exactly what I am aiming for…

Did you ever get an answer? Also trying to do something similar.

No, but in the end I have up. Went back to play other games

I was just trying to change the number of points for raising the level in the dawn of masteries mod, unpacking the mod files, game files, replacing the playerlevels.dbr file, packing it through the assetmanager, it starts deleting the mastery files, saying that they are not linked.

It will delete the unlinked content of the .arc files, which is basically all of it. Just keep using the original arc files.

Your .arz file should be fine, provided you have the custom template in whatever dir you extracted the GD database to during the AssetManager setup.

too hard…

Not sure why keeping the original arc files would be hard, but ultimately this is your decision.

It really is not hard at all (that change would probably take me a minute). Assuming you are not computer illiterate you can probably figure it out in an hour or two with a bit of googling.
I know of several people with no modding experience that have made some small tweaks like that with similar help I provided here.

Sorry if I’m bringing up a rly old thread, but I am having problems with trying to edit a mod myself and was wondering if anyone can shed some light onto the problem I’m having please…?

I correctly set up the asset manager, also to read the additional browse and source directories for gdx1, gdx2 and I have also included the mod files that I wish to edit.

So, I successfully extract the grim dawn game files, and I can edit the mod as it shows up in the drop down bar (I extracted the .arz and .arc files so I can use the asset manager to read the mod files)

However, this is where I become baffled.
I can edit the mod by changing the skills and items etc, and then I save.
Then I build.

I get a message asking me if I wish to delete any unused resource files or something like that, and I click “no to all”.

Then, when the build has finished, I try to enter the game.

Everything is messed up. The graphics are all different colours, the hp,energy bars are missing, skills missing, my character is floating with his arms out…
This happens no matter how many different ways I try of fixing the problem - I am so confused…

Is it because of the removing of all the files from the mod that are listed as the mod I’ve edited is being built…? (I’ve no clue why it removes these files btw)

Please, would anybody know what the heck I am doing wrong…?

Any help would be greatly appreciated, as I am completely at a loss.

Thanks again.

It removes all source files for which you have no corresponding asset file during the build process. The next question is whether you even have source files (eg .tga, etc) or just the compiled .tex, etc.

The safest way would be to take the arcs assetmanager creates and use archivetool to add all the missing files of the original mod to the arcs.
If you did not make any changes to the source part of the mod (only the database part), simply keep using the original arcs

Thanks so much for your reply. It seems that, no matter what I try, I can’t get it to work.
I am going to learn to give up! Thanks again :slight_smile: