[REL] Grimarillion v90d

Sorry, I just realized there’s another expansion the FG. I just bought it 5 minutes ago. I will try the grimarillion again.

Happy hunting! :ok_hand:

Yup, thanks.

I’m crashing when I interact with the blacksmith in Devil’s Crossing and I can’t seem to locate the stash search function (probably due to modded stash).

Missing an updated rainbow mod for it, since the old one doesn’t work apparently.

Been updated already.

Unless I’m mistaken Grimarillion has its own version of rainbow mod? @Matougi

Doesn’t work, my game crashes to desktop when talking to the blacksmith.

Grimarillion hasn’t been updated yet.

Thanks for the heads up. Awesome mod by the way. You have my wholehearted support.

Sure, I updated updated the file to v1.1.4.0. :slightly_smiling_face:


Eta on next update?

@Matougi Thanks a lot! It’s been working great most of the time, but I think I found a bug/mistake (?) just now:

This tome shows up as white in the name, but it’s actually green (common items are disabled in the filter).

1 Like

Thank you for reporting. It’s a D3 items’ file and I forgot to add it after coloring.
I corrected it now.


1 Like


When I wanted to craft something from the Blacksmith (Ulgrim/Duncan) in the Devil’s Crossing it just crashes, crash don’t appears when playing without mod, tested it. Tried reinstalling the game and the mod, same problem appears, is there a fix to that?

I think Okami fixed the crash already, it was some crafting recipe that was looping, referencing itself. Asylum will add it in the next update of Grimarillion! You can play fine as long as you don’t interact with the blacksmiths. Hopefully there will be an update soon :slightly_smiling_face:

Edit: I noticed that the Mirror Image-spell in Wizard doesn’t seem to work. Nothing happens when I’m trying to use it. Not sure if this a Grimarillion-specific issue or if it’s an issue in the D3-mod. I did browse a bunch of posts in the D3-thread but didn’t find anything about mirror image being broken.

It has the same issue in the D3 mod, it seems that it requires a target to spawn the images.
Changing the skill to skill_spawnpet fixes it.

1 Like



*Applied D3 update 2.93:

  • Fixed “Shadow Glide” missing from Demon Hunter tag
  • Added cosmetic animated wings of mercy craftable at the blacksmith
  • Fixed an error in one of the blacksmith recipe that was going to crash the game with the upcoming GD patch
  • Reduced the size and changed the texture of one of the angelic wings

*Applied Stasher update v10:

  • Added search bar
  • Small UI tweaks

Known issues:
*This update doesn’t have a different version number, but consider it to 68a, it was primarily intended to fix anything broken by


Hi, @ASYLUM101! Just found a little typing error in the Lefebvre’s Soliloquy. It has a “]” in the end of its name.

hello.I find Wizard’s skill Ray of Ice have error texture ,v68a still not fix it.

Yes, it’s bugged currently:

I think it was already fixed in D3, and will probably arrive in the next Grimarillion update.

@Matougi Found two more :grimacing:


1 Like