Simple Map Making for Dummies

Oh yes, this is actually something i can answer! If you don’t select a region when in layout mode, this will happen when in editor mode. It doesn’t have a region to center on, so it defaults to absolutely nothing.

You can fix this by going up to the top and open up the drop down bar, and select one of your regions from that. Then you’ll be centered on the region you chose. This will be especially helpful when you start making really big maps and don’t wanna drag yourself around to find one, or you make caves somewhere and you wanna jump to it really quick.

So there seems to be wrong when testing my map as the character can’t move at all - any idea on what might be causing that?

Did you paint any impassable area’s under them, put them on an incline that might be too steep, or possibly place them too close to an object?

its in the guide but still going to make sure you “Rebuild Paths” and Maps and compiled (Build) your mod again after, with the asset manager.
Because thats usually the issue I get when I didnt do any of that :slight_smile:

Figured it out thanks.

i Followed the tutorial and i can select my mod “TestMod” in main menu. But instead using my “Testworld” with the one “Testregion” it shows a “” that is similar to the main campaign. does anyone know this problem? i Tried with and without spawnpoint and in my Testmod folder there is no single File or Folder thats named world001…

Edit: i almost forgot to write that the asset manager crashes every time i build after changeing something in the editor. before it crashes i can read the line Build Time 0.1seconds. If i start it again it does build without errormessage, but takes 0.0 seconds and doesnt seem to do anything

Do you build all pathing, all maps in the editor, then close the editor and then build your mod with asset manager ? Because you can’t build your mod with the editor open and if you overclick the asset manager it will crash.

once i finished changing my world i do the following:

  • rebuild all Pathing
  • rebuild all Maps
  • Save all
  • Close Editor window
  • start Task manager and make sure the Editor Process is closed, too
  • start asset manager as Admin
  • Build
    then i can see the folowing:

Compile time was 0.01 pretty much looks if it finished building and took 0.01 Seconds. so is this error caused by an other one that also causes my problem, or does it crash before being able to write the successfull compiled world from the RAM on my HDD, making my Mod empty wich could cause the main campain to appear? I can remember i had the same error in TQ long years ago, but i cant remember the resolve.

if i restart the Assetmanager and build again i can see the folowing results in the log:

could it have something to do with the first step, Extract game Files ? the Path the asset manager showed me on default was “C:” wich didn´t seem correctly so i changed it to C:\Program Files (x86)\Steam\SteamApps\common\Grim Dawn\source and it made all stuff available in the editor (objects, terrain, textures,…) and seemed to Work.

Curious why I can’t make a region 256 x 256 meters (like in your screenshot)? The highest mine goes is 128 and can’t type into the field (dropdown menu).

256x256 was patched out since this post was made.

Patch changed something.
Doing the same as always the Asset manager did something diffrent then it used to do, and it took about 10 Minutes.

It also showed some Deleted unassociated resources in the Log. Starting the game I couldn´t see the menu, just this:

After Reinstall evrything is back to the old again.

Was this issue ever resolved? I’m having the same problem except everything builds fine and the asset manager doesn’t crash but when I load GD and try to run my mod the only map there is world001 so I just get the default game.

Nice guide, helped a lot.

I have a question. What if I want to add a dungeon entrance which leads to an underground area? Do you just create a region a certain distance away from, say, “ExteriorA” (Let’s say it’ll be called “InteriorA”) so it doesn’t conflict with the minimap, and somehow link a dungeon entrance from ExteriorA to InteriorA’s dungeon EXIT (and vice-versa)? I have been searching and haven’t really figured this out.

Just getting into modding for this game and understanding this would jump start me to creating alternative worlds and campaigns. The mod tools are extremely robust and I’m excited to get started.

rises from the dead

I wish I could help you guys, but it’s been forever since I did this tutorial. I don’t even remember how to do all this stuff, lol.

Never click “Build” or F7 in the Asset Manager when you have no mod activated and your working directory set to the game’s installation directory. It will overwrite all game files and delete everything because it tries to match it with a zero content mod and therefore thinks everything in the files is old and can be deleted.

One more reason why I usually recommend people to create a separate working folder.

Yes, that’s exactly how it works. In TQ there used to be a grid system for undergrounds but GD simply uses maps with a dark day / night layer so it looks like a dark interior.


So I’ve followed this tutorial. Played a little bit with creating tools and brushes. Added “spawnplayer” point. Builded all these in the asset Manager but…

I Can chose my custom map at the title screen of Grim Dawn
However when I press start the game starts in the begining of act 1 map.
So how can I play my map?

I see the forum is dead :confused:

Oh, honestly, it’s been so long, I no longer remember how to do most of this, lol
Not sure I could help you at all

For future reference: Make sure when you create a new world that you save that world file in the Maps folder along with any new terrain files you create. I just found this out and made a post about it.