[Tool] Grim Internals

Well, it has plenty of other features people find useful. But in your case you no longer have need of this tool if that’s all you want since the devs baked it right into the game (which they did as a result of this feature in this very tool).

Because it still has some features people like using like teleporting to dungeons.

It’s a recent QoL feature because so many people kept whining and complaining when Glockengerda didn’t update the mod almost immediately every time a patch came out that Crate decided to add it to the game. This from the 12th June dev stream:

“The patch just came out and every forum, every reddit, discord, was like oh my god I can’t play the game because Grim Internals doesn’t work, I want my autoloot. So it’s like FINE, we’ll make it so you don’t have to reinstall Grim Internals every patch to get your autoloot. Coming in the next hotfix, probably next week, we’re introducing autoloot for components and crafting materials. And whenever you loot a component, whether you loot with autoloot or manually, it will automatically combine with any of those components in your inventory. Yes, you can turn it off, it’ll be off by default, but we’re going to make that an option in the game options that you can make that automatic autolooting components.”

1 Like

I guess… Love how Crate actually cares what there players want.
Hows the attitude though lol FIIIINE. It’s only your fan’s saying what they want.
EDIT2: Apparently I have run out of replies. I don’t remember my old Acc pasword and the email attached to it is long gone. Oh well.

It just strikes me as out of the ordinary for DEV’s to give one single shit about any of there fan’s let alone modders lol

Anyway. Cheers dudes

EDIT3: Nah gotta wait 23 hours or whatever for a new user.

1 Like

Ha… well, they do. Plus I think they just felt sorry for Glocken being harassed to update the tool ASAP everytime the devs released a game update.


lol in the panel to the right…

… that area did it tell you that you were maybe posting too much? you can ignore that, FYI, and post/reply anyway :wink: for future reference.

And yw.

1 Like

Crate have added several things suggested by the fan base over the years and even had a few polls early on in development to garner players’ opinions. Devil’s Crossing was named by such a poll.


Hello, is there any way to autopick epic/legendary items with GI too, i can´t find anything about it^^

This has been ask for before, but GlockenGerda doesn´t want to implement it.
Which is fine, imo.

GrimInternals does not support pirated copies…

(The game exe has been altered/cracked and therefor GI doesn’t like that)

GD goes on sale alllll the time. Support the developers and buy a copy!!


well i’Ve used GI for Game-Speed for example when im farming my Routes for Materials etc. or Lvling a new Character… mostly playd at 2.00-2.50 Game Speed

Can’t get the GrimInternals to work it shows like this https://imgur.com/a/NZ0yXV1 any ideas how to fix it

see Q&A in OP.

1 Like

It has something to do with the DPI settings but still the same i tick Override high DPI scaling behavior & set it to Application, Grim Dawn is having that setting i don’t know what else to do.

have you tried everything that is suggested in the Q&A post?
IF you believe that you did everything 100% percent and still you got problems then the only solution would be to disable the scaling in your OS :confused:

It cant be fixed in any other way(even tho some ppl tried the suggestions and it worked) cause the author has to rewrite most of the tool from the start and its not really recommended atm

The DPI scaling is disable in the windows settings and still i get the same resaults, any way its no big deal i can play without it. I have also tried everything that is suggested in the Q&A post, but i thought there was a fix for it.

Can’t get CTRL+F5 to work…I dropped all files into install folder, and all of the settings are present in game (Steam version x64, latest version, clean install), allowances in AV made for GI, DPI settings disabled, and I’ve followed every step I can find in the awesome FAQ. All the files are present, but for some reason CTRL+F5 just isn’t bringing up the configuration menu. Any guidance would be greatly appreciated, really looking forward to using this! :slight_smile:

Welcome to the forum! :slight_smile:

Did you start the game with the provided GrimInternals64.exe?
In the mainmenu is there a GI version number present?

btw: CTRL+F5 works only in-game, not in the mainmenu.

1 Like

That seemed to do it! Feels ridiculous, but I didn’t realize you had to be past the main screen :rofl: Thanks for the help!

I…I want these fonts :o

Indeedthere is not any mention that in the Q&A the CTRL+F5 only in game wasn’t mentioned
Dully noted