[Tool] Grim Internals

nice job! thanks alot for sharing this!


I have a super small FR request:

Now with a long teleport list, i found it annoying that the list always starts from top when using the dropdown arrow to pop out the list regardless of the formerly chosen position.
id rather have it to start/jump at that position that was formerly chosen.

eg when farming some mobs in a given act, its annoying to scroll down to the fitting act again if the list is that long as the one recently provided by Kortique_Alavier.

1 Like

For a fast repeatable teleport I you can consider moving to Custom Game
where you can teleport with command line. And also get current coordinates.
You only need to input command once and then it’s saved and can be bring back with just Up Arrow iirc.
I used it while farming rep to teleport right next to Bounty Table in Devil’s Crossing.

Read through the FAQ… When I disable cloud save and restart GD as recommended my character gets removed. If I re-enable cloud save and restart it comes back. Tried disabling and enabling CS in steam options for game, and in GD itself. Am I doing something stupid?

So if I have cloud save disabled and launch GI/GD my character is missing.

I backed up the file 219990 from steam, but it doesn’t seem to be getting character from there anyway, and there is nothing under save folder in GD install

Any advice?

Solved…Moved the backup to documents/my games/grim dawn/save…

Welcome to the forum. :slightly_smiling_face:

Make sure cloud saving is disabled in both the Steam settings and the ingame Options menu.

And maybe read this for some more info How to - Move your saves from Steam cloud to Grim Dawn's default location.

Appreciated, but current download triggers Windows threat detection within the RAR file.

That’s a massive teleport list; thanks for sharing!

One issue I noticed is that the filename of the teleport list in the folder /Eng/Standart+Totems+Nemesis contains a space just before the “.txt” file extension (GrimInternals_TeleportList .txt").

Added a link to the first post:


Microsoft Edge attempted to block the download on me as well (which I ignored). I’m guessing it’s possibly because it might not “trust” Yandex (a russian site) - web browsers also behave the same way with Mega downloads often. I then scanned it with Windows Defender and it came back clean - and the insides appeared fine as well.

One issue I noticed is that the filename of the teleport list in the folder /Eng/Standart+Totems+Nemesis contains a space just before the “.txt” file extension (GrimInternals_TeleportList .txt").

Oops. Fix it.

> Added a link to the first post:

Thank you, it’s very nice when your own work is not wasted.


You still read these threads about your brainchild here? Excellent. I MUST KNOW what goes behind the animals. I had a large Siamese cat the other day.

Oh - and thank you so much! I’d donate if you had a mechanism, but currently I can only lavish you with praise.

No, I scanned it after download - I do not use Edge. Still threat. I extracted the text file, obviously that’s fine, but there may be something else in the RAR itself that maybe the author doesn’t know about.

I scanned it after with Defender… came back completely clean.

Malwarebytes is also giving it a clean bill…

Also, I just now loaded it into VirusTotal for ya…


Not a whisper. Dunno what’s up with your copy of Windows but I’m not seeing that issue here.

Is it possible to log your death(s) and look at it? I die all the time to one certain boss and would like to know how I die in 1 sec.

GI has an option for screenshots to be taken when you die.

You can also make a thread with your character (Grim Tools) / boss you’re fighting with / maybe even video and people will explain to you why/how you die.

i think (not yet tried myself) you can get the developer console when you start a custom game. and i think GI offers some options to log that stuff to a file. Dont ask me how to open the console. (usually its the ^ key) .
so if you could replay/load that scene intoa custom game you should be able to get verbose information (my hypothesis)

Grim Internals Help (sorry not sure if this is right spot)

I’ve been using Internals for a month or two now, when I try to start it up today I get

“Grim Internals v1.99b is not compatible with your version of Grim Dawn…”

Can anyone help?

GD sent out a patch today, so you’ll need to wait until Grim Internals is updated.

Oh, that make sense, haha, thanks!


Grim Dawn had a new patch today.

Grim Internals will be updated soon, as @GlockenGerda always does.


1 Like