[Tool] Grim Internals

Yes, you’ll have to wait for GlockenGerda to update the tool since GD got a small patch a few hours ago.

Damn it. Exactly with the release of a new Hotfix in RoT.

I wanted to be a smart-ass and tell you that you shouldn’t have updated the game.

But mine has updated too even though I had everything as usual
(update only when launching the game* + launch only with GI + have Steam running before launching GI)

*so I looked into Update options and of course - it switched to Always keep the game updated on its own :man_facepalming:
I had it happened to me in the past many patches ago as well.

@powbam I tried your way of downgrading the game, worked really well, I found manifests on steamdb.info but in the end I decided not downgrade because I have a huge mess in my Grim Dawn folder and files I would need to copy to a new folder. And 1.1.9.5 contains some hidden changes to find out :thinking:

2 Likes

There is something wrong with this installers verification system. Ive also got Version Mismatch error while having the latest GoG version of the game.

Welcome to the forum. :slightly_smiling_face:

As said many, many times here when there’s an update to GD (which there was a few hours ago) GI gets broken. Everyone has to wait for @GlockenGerda to update GI to work with the latest game version.

2 Likes

Grim Internals (x64) v1.105 for GD Patch v1.1.9.5
Download-Link (MEGA)
Download-Link (Google Drive)

Known issue:

24 Likes

Thumbs up yet again. We luv u.

did you make it impossible to move the character after TPing?

You’re amazing Glocken Thank you.

Seriously, is there any way we can get a Black Legion marksman NPC renamed Glock-n-Gerda as a tribute? Her tool is one the the things that allows me to evaluate new builds, and new builds are what keep me coming back lto GD.

i love how reliable an spiked increase of unread posts in the GI thread correlates with the rollout of a new patch :slight_smile:

1 Like

You’re the best Glocken!!!

Danke schön, Frau Glocke. :kissing_smiling_eyes:

After I installed the latest patch ,CreateRemoteThread()failed!

After I installed the latest patch , CreateRemoteThread()failed

Hmmm… I remember having this a couple times and I think for me restarting my computer always worked.
I think it’s some process hanging out unnecessarily

this problem has always been, and with it a bunch of other ones))

Thank you, much appreciated.

FYI, I had some initial trouble with running GI v1.105.

After applying the update and running GI (Steam was already running), Windows Defender stopped the app from starting. That was the first time it ever happened as far as I remember. I chose to run it anyway, but then the next error occured, Grim Dawn thought Steam is not running, and GI didn’t find grimdawn.exe.

Restarting the PC fixed it though.

Hi! Any way I could change the default colour of monsters’ health bar from green to red like in the base game?