[Tool] Grim Internals

I downloaded and installed the latest version of GDIA and tried to reproduce the problem but to no avail.

Hence my question to all GI users:
Have you ever experienced similar problems, did you also have items disappeared and if so, did you use GI alone or also used GDIA at the same time?
Also please state here whether you were using the Steam version and if Cloud Save was enabled or not when the problem occured.

The more information I get about this problem, the easier it could be to isolate the problem.

Thanks for the speedy reply and test!

For reference, there’s a thread here with reports of similar issues. The common denominator seems to be folks using GI, GDIA, or both.

I’m pretty sure whatever happened to my toon is permanent at this point, but definitely worth further troubleshooting. Not sure if there are any logs worth looking at?

Since my build was completely fa##$ i used a cheat tool to get my build back and devotions didnt change anything else, back to normal.

can someone shared me, Grim Internals for 1.1.7.2v. i guess is the 1.97.

Thx!

Just download it from the link in the opening post.

I’ve figured out how to run Grim Dawn base game only, so I can play multiplayer with friends. To do this, I run from steam with Set Launch Options set to “/x64 /nogdx1”. Can I do this using Grim Internals?

EDIT: It’s entirely possible, I mis typed in my shortcut before posting. It does work.

  1. Create Grim Internals shortcut
  2. Shortcut Properties > at the end of Target after the inverted commas add: /x64 /nogdx1

No need to add /x64 on a GrimInternals shortcut. It only launches x64 GD by default.

1 Like

no no, that file is for 1.1.7.2 hotfix 2 , i need the version without the hotfix. Anyone have it? thx!

No, because Gerda doesn’t keep old versions of GI.

Gerda doesnt keep, but no one keep it?

Why would they? Everyone uses the most up to date version of the game and so the most up to date verson of GI.

1 Like

Grim Internals (x64) v1.97c for GD Patch v1.1.7.2 Hotfix 2
Download-Link (MEGA)
Download-Link (Google Drive)

v1.97c

  • fixed a bug where GI could crash on startup (thanks @Tuoppi for providing me with a crash dump file)
  • Dealt DPS list: renamed damage type “Aether” to “Magic” when playing the mod ReignOfTerror

Known issues:

  • Steam Cloud Save is not functioning properly when you launch Grim Internals!
    To prevent possible data loss, disable Cloud Saving (both Steam and In-Game)!
4 Likes

As I said, I can’t reproduce the issue and I got no new informations that would help
to investigate the issue.

ok so, every people in this forum delete all GI files after upgrade it. No one just let the file in a X folder, like me. They are very neat

I recommend always to use only the newest GI version, because it contains the latest bug fixes!
There is no need to keep old GI versions!

2 Likes

yes GG, i know what you say. But the crackers don’t update the hotfix’s of games. Cause is not super necessary to play the game. So , i dont have the money to buy the original game right now, i want to prove it first anyway. And everyone recommend me to use your MOD. But dont worry, sorry for waste your time. thx

And this is partly why Gerda doesn’t keep old versions of her tool. Also from the Q&A for the tool.

"Disclaimer
To edit the GrimInternals.ini file open it up with any notepad programs you prefer. Also keep in mind that PIRATED versions will not be supported "

When you have a legit copy of the game then I’m sure she’ll be happy for you to use her tool. And Crate will be happy to see you back here when you do.

4 Likes

Hey… didnt quite see my issue listed here:

  1. Last night, installed Grim Internals and Full Rainbow.
  2. Followed the directions; both mods worked just fine; character loaded up as normal.
  3. Played for awhile.
  4. Went to boot up today… character is missing.

When I installed Grim Internals… I forgot to turn off Cloud Saving in-game.

Googling the issue, I discovered that my Cloud saves could be found in the STEAM folder. I tried copying + pasting those into the local GD files… but when I load back up (after turning off Cloud saving), the character still is not listed at startup.

Any suggestions / advice would be much appreciated.

This isn’t actually GI. It doesn’t do anything with character files. But, make sure you have the cloud turned off both IN STEAM and IN Grim Dawn. Copying the files over into your GD main/save folder should do the trick after that. If you want to make sure to always have a back up as well, I’d recommend turning on OneDrive and have it keep a backup of the GD Main/Save file. That way you’re not technically using Steam cloud/GD cloud but you’ve always got a back up to fall back to.

Or not since OneDrive is also known to muck about with saves.