[Tool] GD Hacker GUI for x64 / game speed, teleport [discontinued]

Discontinued - use [Tool] DPYes - Player/pet DPS meter & Misc util instead

Russian keyboard not supported atm (speed change works though).

Light skin can be chosen in the config file.

GDHackerGUI_1.2.0.3_GOG.zip (895.3 KB)
GDHackerGUI_1.2.0.3_Steam.zip (895.4 KB)

Installation & launch

  • Make sure you play the proper version of Grim Dawn by having x64 and game’s version in right lower corner in Main Menu.


  • The files don’t need to be extracted anywhere. Just put the folder with them wherever you want and (recommended) make a shortcut to GDHacker.exe and put it on your desktop so that you never have to look at these other files (unless you want to change something in the .txt files) and be confused.

  • Launch GDHacker.exe. It doesn’t matter if it’s done before or after launching Grim Dawn.

  • if the buttons are not being highlighted when you hover over them while the game’s launched, it means the program is not working correctly

  • check out options config.txt to adjust the program to your preferences

Navigation with  :keyboard:

How to use GDHacker efficiently with keyboard only example

  • (optional) you launch the game Alt + L from GDHacker

    [there will probably be a Launch GD (or Launch GD button)
    so that you can launch the game with Alt + L (or Alt + G)]
    if the game’s already opened the button will just go to the game / activate it’s window

  • you choose your character, get into the map and Alt + Tab till you switch to GDHacker

  • you change the speed by pressing Alt + S
    (although there will probably be automatic speed change available)
    [can be done when you’re in Main Menu, not necessarily in-game with your character]

  • Tab Tab (or Shift + tab)… to Location List and select a location using one of the 2 keyboard methods shown in the Teleport section in this post

    • to open the list, press Alt + Up/Down

    • GDHacker will probably launch with previous location already selected (I’ll add this behavior)

  • Alt + T to teleport and go back to the game


Detected as malware

[update] I managed to change the way I compile the program so that most and reputable AV companies don’t report it as a threat. You can see Avira, McAfee, Malwarebytes, Symantec etc below … Some other companies just don’t respond to reports of their detections being false positives / don’t analyze it further.

Even if you make the simplest program in AutoHotkey such as
MsgBox, Hello World! it gets a few detection like that.

It’s a false positive. The program only creates GUI, saves to config.txt and changes some bytes in the Grim Dawn process. I’d never try to harm users of my programs (I don’t even know how to), have a solid reputation of helping others (nearly 6k :+1: on this forum) and don’t want to lose that. You can read or search this thread that nobody has reported any suspicious activity (and I can’t delete posts here). Also if necessary, I’m willing to give some well-known person on the forum access to my repos and even have them compile the programs / prepare releases on their own if needed.

You may not know this, but anti-virus programs are not that smart and they just flag everything that is unknown / suspicious / hard to analyze for them. It’s even more common problem for AutoHotkey programs. The “hacker” in the name doesn’t help either I guess.

But I used it deliberately because that’s my character, I don’t like BS and call everything for what it is. And this field is called “Game Hacking”. Grim Internals is way more invasive that my little program despite being just “Internals”. But GlockenGerda is a much better developer than me, probably used a more popular programming language like C++ and knows better how to avoid being flagged like that.

Other GD trainers and Cheat Engine (which is a very popular, main stream tool) are also detected as malware, you can check it for yourself, so maybe it just goes with the territory.

You can even get flagged if you make a Hello Word program in C++ Hello World c++ program reported as Trojan:Win32/Wacatac.C!ml by Windows Defender

Even :crate: has problem with anti-viruses:

I think my machine is also clean as I scanned it with multiple tools over the years and I never had any viruses except some bitcoin miner embedded in a South Park episode.

trojan wacatac false positive - Google Search

My antivirus program flagged AutoHotkey or a compiled script as malware. Is it really a virus?


  • doesn’t have GI’s restrictions - for example you can teleport into roguelike dungeons / directly to Crate etc.

  • reads the good ol’ GrimInternals_TeleportList.txt (proper encoding might be needed currently)

  • either click a button or press Alt + T to teleport

  • how to select location efficiently with keyboard if having a lot of locations
    (and if you don’t want to use a mouse)

    1. to open location list with :keyboard:, press Alt + Up/Down

    2. pressing letters to jump between locations starting with a letter (B in this example).
      This can be done with the list either closed or opened as seen in the gif

    3. searching for a location by typing its prefix, for example Dev for Devil’s Crossing which is possible with Sort enabled in the config
      This can be done with the list either closed or opened as seen in the gif

Save location (coming soon™)

Game speed

  • either click a button or press Alt + S to change game’s speed

  • can be done when you’re in Main Menu, not necessarily in-game with your character

Mogdrogen reset

  • you need to be in-game not in Main Menu

  • Alt+Tab to the program and either press the “Reset Mogdrogen!” button or Alt + M

  • after that you need to restart the session (go to Main Menu and then in-game again)

  • Mogdrogen should be willing to fight with you again

    • of course I recommend teleporting to him using the program

For some reason the teleport doesn’t work. The console says unknown command. Or do I need to enter the command in the console? Then which one?

One important thing - of course use it when console is not turned on because the program

  • goes back to the game
  • waits for a bit
  • turns on console
  • waits a tiny bit
  • types the command
  • presses enter
  • hides the console

I mean you could enter the Game.Teleport x y z command but the program is supposed to do it for you.
I might need to tweak is so that it works on your end too - maybe it inputs some buttons too fast so I should put some delay somewhere etc. Or maybe some button is interpreted differently on your end.

  • When it says unknown command what does it also say precisely? Run it multiple times please.
  • What’s your Grim_Internals_Teleport content and for which location it doesn’t work?

On my end it looks like Grim Internas now (if you have console unlocked that is)

  • you click teleport and it goes back to the game and teleport
  • although you might see command being typed quickly
  • doesn’t work like 1% of the time

I might send you some version that input the command very slowly so that we see if it’s correct or with configurable delays, sth like that.

1 Like

After you explained how it works, I figured it out. The keyboard layout was not English. Now everything works. Thanks a lot!

1 Like

Oh, cool! Anyway, I’ll still add some debug options to GDHacker.txt for debugging purposes later, sth like this


so that a user can increase cmd_time_before_enter to 5000 (it’s in ms) and easily see what’s being typed

How can I fix this? Teleport list in Russian. UTF-8 encoding.

Send me the file, it will be faster this way, I’ll try to make it compatible

I’ve already fixed it. Converted the file to ANSI. Everything is beautiful now. Thanks again! :slightly_smiling_face:

1 Like

how to make the game speed increase? i put 2.0 and hit the button but the speed stays the same.

First of all - Do you play x64 Grim Dawn? And
You can also try running it as admin.

1 Like

My bad. I thought i was playing the x64, it turns out i wasn’t. i opened in x64 and worked. Thank you for the tool man! and R.I.P. grim internals.

1 Like


Is it possible to align the name to the left?


掠夺者 Ravager, -1600, 10, -3600,
板条箱 Crate, -4600, 10, 6550
马蹄莲 Calla, -4150, 10, 6000
恶魔十字 Devil's Crossing, 58.85, 10.50, 65.31,

Have you considered making your program capable of recognizing UTF-8 encoded text? This might solve the problem.

1 Like

I prefer centered but I can add an option for left alignment in GDHacker.txt if you want

Send me a GrimInternal_TeleportLists of yours encoded like that, then I can try to make my program work with it. I prefer adjusting the program to files of users, not making my own files like that.

By the way, current progress update:

  • saving location doesn’t work yet (I need to find current coordinates in the memory)
  • other things, including Teleport, working in Main Campaign now, not only in Custom

Where can I get the updated program? I thought I would update, but everything remains the same.

@valet2valet Added the current version, not having auto-update yet.
It’s not a very high priority for me and I have never done sth like that so it’s not like I could add it in 5 minutes.

1 Like

Oh, thank you very much. I’ll test it.
Update. Everything works perfectly. Many thanks for your work!

1 Like

GrimInternals_TeleportList.txt (167 Bytes)


1 Like

Great tool. I have a problem, instead of showing and hiding the console the teleport command goes to the game and shows the Escape menu

1 Like

I found something suspicious in the code and fixed it. Please redownload the program and try the again.

1 Like

Im running the x64 version and the game speed does nothing, even if I run gdhackergui in admin mode. Is there any way to get the current coordinates of the character? I couldnt find anything online on how to do it