[Mod] Reign of Terror

Install in that order: => => =>

Portal to Tristram in The Ancient Archives doesn’t open:

GT branch for RoT mod is updated to patch


Much appreciated. :kissing:

Man how this mod has changed. I only get like 1-2h a day to person things so thought early today to try this mod again, this one is much more fun that ver I think 0.6. The older version was so slow paste. Was like watching paint dry. Now on to another thing

This item has Tag not Found:

Hello all! I tried to install the mod, but when I tried to extract it, 7-Zip gave quite a few “Data error” messages regarding various files (TerrainTextures.arc, testingrounds.arc, etc.). I downloaded each file from Google again (MEGA says my quote would finish before finishing the download of the 4th file, so I did not manage to download all of them from there), and it still gives data errors.
Any idea what to do?

You’re likely not on the latest update.
Curremt version of RoT is
See the download link here: [Mod] Reign of Terror - #6938 by Fuzzydunlop [Mod] Reign of Terror - #6953 by Fuzzydunlop and above will require GD patch I can recommend to back up your characters before updating to these.

Try the links from the discord, or a different browser. If both dont work let me know and ill re-upload the files on google again

Thanks for the suggestion, downloading with another browser helped, now I get no data issues.
As I started playingm one thing I noticed is that GD objects (craftable items at the anvil, GD classes) are still available, is that intentional?

Yes, most of GD items are part of the mod, including the crafting stations.

Main post has been updated with the latest version.

Both links are the same, please correct it.

Not sure if the hotfix will fix this. After update my main character does not get experience and the xp formula is back to paint dry.

How to solve the stone puzzle for search cain quest. I think i did the right order but nothing happens so i have to redo the quest again to get the scroll of infinus with the quest fix. tried 5 times already.

I updated the mod with the latest version and the hotfix and that’s what happend :roll_eyes:

Now it’s working … I downloaded all files again and installed all new. :sweat_smile:

You need the standalone first (, which is the big download with 5 7z files. Then apply patch and the hotfix.
Edit: missed your edit

It’s weird that I have to install the mod completly new … I already played it, so I thought the update would be enough. Well, I was wrong … :laughing:

Do you guys have random freezes where you have switchto task mngr and end process. I have it pretty often 4-5 times in about 2 hrs.

It varies from person to person, and from pc to pc. You can try some things, like forcing multiple cores (GD uses 1 by default), set dhadows to high or off (low or medium tends to cause more crashes) and some people report that they mainly crash while using holy fire/shock.
These things help some, but not others. Others barely crash at all without having to change anything.


Thanks for the report.